OMSA: No controllers found

OMSA tools (command line and web-based) see but do not display PERC5 controller nor any of the array info. MegaCli displays everything fine.

I am battling with this problem for several days. I tried several solutions as suggested in various places on the net, to no avail. Please note that OMSA daemons appear to recognize the controller and see the disks, however both omreport and web-based GUI complain that no controllers were found.

Symptom of the problem:

# omreport storage controller
No controllers found

The web-based OMSA GUI also displays this message in "Storage" folder, which is otherwise shown empty. Other folders ("Main System Chassis" and "Software" are populated and seem to be working fine

Hardware: DELL PowerEdge 2950

Centos 5.4 64 bit

# uname -a
Linux peta.swmed.edu 2.6.18-164.9.1.el5 #1 SMP Tue Dec 15 20:57:57 EST 2009
x86_64 x86_64 x86_64 GNU/Linux

PERC Controller: PERC 5/i Integrated

# ./MegaCli -AdpAllInfo -aALL

Adapter #0

Product Name    : PERC 5/i Integrated
Serial No       : 12345
FW Package Build: 5.0.2-0003

                    Mfg. Data
Mfg. Date       : 00/00/00
Rework Date     : 00/00/00
Revision No     :
Battery FRU     : N/A

                Image Versions in Flash:
Boot Block Version : R.2.3.2
BIOS Version       : MT23
MPT Version        : MPTFW-
FW Version         : 1.00.02-0157
WebBIOS Version    : 1.01-021
Ctrl-R Version     : 1.02-007

OMSA Version
: 6.2.0

# rpm -qa | grep -i srvadmin

The OMSA software was installed as follows:
wget -q -O - http://linux.dell.com/repo/hardware/latest/bootstrap.cgi | bash
yum install srvadmin-all

Driver version:

# modinfo megaraid_sas
filename:       /lib/modules/2.6.18-164.9.1.el5/extra/megaraid_sas.ko
description:    LSI Logic MegaRAID SAS Driver
author:         megaraidlinux@lsi.com
license:        GPL
srcversion:     93C6B7A0CD0B1E64061C3B4
alias:          pci:v00001028d00000015sv*sd*bc*sc*i*
alias:          pci:v00001000d00000413sv*sd*bc*sc*i*
alias:          pci:v00001000d00000071sv*sd*bc*sc*i*
alias:          pci:v00001000d00000073sv*sd*bc*sc*i*
alias:          pci:v00001000d00000079sv*sd*bc*sc*i*
alias:          pci:v00001000d00000078sv*sd*bc*sc*i*
alias:          pci:v00001000d0000007Csv*sd*bc*sc*i*
alias:          pci:v00001000d00000060sv*sd*bc*sc*i*
alias:          pci:v00001000d00000411sv*sd*bc*sc*i*
depends:        scsi_mod
vermagic:       2.6.18-164.9.1.el5 SMP mod_unload gcc-4.1
parm:           fast_load:megasas: Faster loading of the driver, skips
physical devices!      (default=0) (int)
parm:           max_sectors:Maximum number of sectors per IO command (int)
parm:           cmd_per_lun:Maximum number of commands per logical unit
(default=128) (int)
parm:           poll_mode_io:Complete cmds from IO path, (default=0) (int)

Same problems with driver that came with OS:

All srvadmin services start OK:

# srvadmin-services.sh status
dell_rbu (module) is running
ipmi driver is running
dsm_sa_datamgrd (pid 4277) is running
dsm_sa_eventmgrd (pid 5204) is running
dsm_om_shrsvcd (pid 3706) is running
dsm_om_connsvcd (pid 5222 5221) is running

# service ipmi status
ipmi_msghandler module loaded.
ipmi_si module loaded.
ipmi_devintf module loaded.
/dev/ipmi0 exists.

Starting dsm_on_connsvcd causes the following file to be created,
indicating that OMSA daemons do indeed see the controller:

# cat /opt/dell/srvadmin/var/log/openmanage/Inventory.xml.1
<?xml version="1.0" encoding="UTF-8"?>

<SVMInventory lang="en" schemaVersion="1.0" invcolVersion="6.2.0"
invcolBuild="288" timeStamp="2009-12-22T18:28:32">
    <OperatingSystem osCode="LIN" osVendor="Redhat" osArch="x64"
majorVersion="package redhat-release is not installed"
minorVersion="2.6.18-164.9.1.el5" usingTPMmeasurements="FALSE"/>
    <System systemID="01B2" TPMmeasurementsOn="FALSE"/><Device
componentID="2331" display="OpenManage Server Administrator Managed Node">
<Application componentType="APP" version="6.2.0" display="OpenManage Server
Administrator Managed Node"/>
    <Device componentID="159" display="BIOS"
impactsTPMmeasurements="TRUE"><Application componentType="BIOS"
version="1.2.0" display="BIOS"/></Device>
    <Device componentID="5814" display="Baseboard Management Controller">
      <Application componentType="FRMW" version="1.27" display="BMC"/>
    <Device vendorID="1028" deviceID="0015" subDeviceID="1f03"
subVendorID="1028" bus="2" device="e" function="0" display="PERC 5/i
Integrated Controller 0" impactsTPMmeasurements="TRUE"><Application
componentType="FRMW" version="5.0.2-0003" display="PERC 5/i Integrated
Controller 0 Firmware"/></Device>
    <Device componentID="00000" enum="CtrlId 0 DeviceId 0"
display="ST3750640NS"><Application componentType="FRMW" version="E"
display="ST3750640NS Firmware"/></Device>
    <Device componentID="00000" enum="CtrlId 0 DeviceId 1"
display="ST3750640NS"><Application componentType="FRMW" version="E"
display="ST3750640NS Firmware"/></Device>
    <Device componentID="00000" enum="CtrlId 0 DeviceId 2"
display="ST3750640NS"><Application componentType="FRMW" version="E"
display="ST3750640NS Firmware"/></Device>
    <Device componentID="00000" enum="CtrlId 0 DeviceId 3"
display="ST3750640NS"><Application componentType="FRMW" version="E"
display="ST3750640NS Firmware"/></Device>
    <Device componentID="00000" enum="CtrlId 0 DeviceId 4"
display="ST3750640NS"><Application componentType="FRMW" version="E"
display="ST3750640NS Firmware"/></Device>
    <Device componentID="00000" enum="CtrlId 0 DeviceId 5"
display="ST3750640NS"><Application componentType="FRMW" version="E"
display="ST3750640NS Firmware"/></Device>
    <Device componentID="11204" enum="CtrlId 0 DeviceId 8 Backplane"
display="SAS/SATA Backplane 0:0 Backplane"><Application
componentType="FRMW" version="1.00" display="SAS/SATA Backplane 0:0
Backplane Firmware"/></Device>
    <Device vendorID="14e4" deviceID="164c" subVendorID="1028"
subDeviceID="01b2" bus="5" device="0" function="0" display="NetXtreme II
BCM5708 Gigabit Ethernet rev 12 (eth0)">
        <Application componentType="FRMW" version="2.9.1" display="NetXtreme II
BCM5708 Gigabit Ethernet rev 12 (eth0)"/>
    <Device vendorID="14e4" deviceID="164c" subVendorID="1028"
subDeviceID="01b2" bus="9" device="0" function="0" display="NetXtreme II
BCM5708 Gigabit Ethernet rev 12 (eth1)">
        <Application componentType="FRMW" version="2.9.1" display="NetXtreme II
BCM5708 Gigabit Ethernet rev 12 (eth1)"/>

Any help would be welcome. Sorry for the long post.

0 Kudos
21 Replies

Re: OMSA: No controllers found

Hello Magic999;

Please go to /opt/dell/srvadmin/etc and run:

# ./autoconf_cim_component.sh

Then restart srvadmin services:

# srvadmin-services.sh restart

Then try again:

# omreport storage controller

Please let me know if this solves your problem.

0 Kudos

Re: OMSA: No controllers found

I am having the same issue. I just upgraded to srvadmin 6.2.0 and it stopped working. I tried what you mentioned and I am still getting


omreport storage controller
No controllers found



Dec 27 20:39:16 Installed: srvadmin-smcommon-6.2.0-1.29.el5.i386
Dec 27 20:39:37 Installed: srvadmin-fsa-6.2.0-1.6.el3.i386
Dec 27 20:40:07 Updated: srvadmin-hapi-6.2.0-1.17.el5.i386
Dec 27 20:40:09 Installed: srvadmin-storelib-6.2.0-1.11.el3.i386
Dec 27 20:40:09 Installed: srvadmin-sysfsutils-6.2.0-2.1.el5.i386
Dec 27 20:40:09 Installed: srvadmin-megalib-6.2.0-1.6.el3.i386
Dec 27 20:40:09 Installed: srvadmin-xmlsup-6.2.0-1.17.el5.i386
Dec 27 20:40:11 Installed: srvadmin-itunnelprovider-6.2.0-1.6.el5.i386
Dec 27 20:40:14 Installed: srvadmin-omilcore-6.2.0-1.9.el5.noarch
Dec 27 20:40:15 Updated: srvadmin-racsvc-6.2.0-677.i386
Dec 27 20:40:15 Updated: srvadmin-racadm4-6.2.0-677.i386
Dec 27 20:40:28 Updated: srvadmin-jre-6.2.0-1.17.el5.i386
Dec 27 20:40:28 Updated: srvadmin-racadm5-6.2.0-677.i386
Dec 27 20:40:29 Updated: srvadmin-idracadm-6.2.0-677.i386
Dec 27 20:40:32 Updated: srvadmin-deng-6.2.0-1.6.el5.i386
Dec 27 20:40:37 Installed: srvadmin-omcommon-6.2.0-1.19.el5.i386
Dec 27 20:40:38 Updated: srvadmin-rac4-components-6.2.0-677.i386
Dec 27 20:40:38 Updated: srvadmin-rac5-components-6.2.0-677.i386
Dec 27 20:40:39 Updated: srvadmin-idrac-components-6.2.0-677.i386
Dec 27 20:40:47 Installed: srvadmin-smweb-6.2.0-1.29.el5.i386
Dec 27 20:40:49 Updated: srvadmin-isvc-6.2.0-1.16.el5.i386
Dec 27 20:40:53 Installed: srvadmin-omacore-6.2.0-1.18.el5.i386
Dec 27 20:40:54 Updated: srvadmin-storage-6.2.0-1.29.el5.i386
Dec 27 20:41:04 Updated: srvadmin-iws-6.2.0-1.18.el5.i386
Dec 27 20:41:05 Updated: srvadmin-cm-6.2.0-677.i386
Dec 27 20:41:05 Updated: srvadmin-base-6.2.0-1.5.el5.i386
Dec 27 20:41:05 Updated: srvadmin-standardAgent-6.2.0-1.5.el5.i386
Dec 27 20:41:05 Updated: srvadmin-webserver-6.2.0-1.5.el5.i386
Dec 27 20:41:06 Updated: srvadmin-racdrsc4-6.2.0-677.i386
Dec 27 20:41:06 Updated: srvadmin-rac4-6.2.0-1.5.el5.i386
Dec 27 20:41:06 Updated: srvadmin-idracdrsc-6.2.0-677.i386
Dec 27 20:41:06 Updated: srvadmin-idrac-6.2.0-1.5.el5.i386
Dec 27 20:41:07 Updated: srvadmin-racdrsc5-6.2.0-677.i386
Dec 27 20:41:07 Updated: srvadmin-rac5-6.2.0-1.5.el5.i386
Dec 27 20:41:07 Installed: srvadmin-storage-populator-6.2.0-1.25.el3.i386
Dec 27 20:41:07 Updated: srvadmin-storageservices-6.2.0-1.5.el5.i386
Dec 27 20:41:07 Updated: srvadmin-all-6.2.0-1.5.el5.i386
Dec 27 20:41:11 Erased: srvadmin-wsmanclient
Dec 27 20:41:11 Erased: srvadmin-syscheck
Dec 27 20:41:11 Erased: srvadmin-omauth
Dec 27 20:41:17 Erased: srvadmin-ssa
Dec 27 20:41:18 Erased: srvadmin-omhip
Dec 27 20:41:19 Installed: srvadmin-omilcore-6.2.0-1.9.el5.noarch
Dec 27 20:41:51 Updated: srvadmin-deng-6.2.0-1.6.el5.i386
Dec 27 20:41:52 Installed: srvadmin-omacore-6.2.0-1.18.el5.i386
Dec 27 20:41:52 Updated: srvadmin-iws-6.2.0-1.18.el5.i386

0 Kudos

Re: OMSA: No controllers found

vvladg, thanks for your reply. Unfortunately, the problem persists.

# ./autoconf_cim_component.sh
Configuring wsman...........
Saving /etc/openwsman/openwsman.conf as /etc/openwsman/openwsman.conf.rpmsave ...
Creating ssl symbolic link....
Configuring sfcb....
Saving /etc/sfcb/sfcb.cfg as /etc/sfcb/sfcb.cfg.rpmsave ...
Updating pam app (/etc/pam.d/openwsman) for openwsman....

# srvadmin-services.sh restart

Shutting down DSM SA Shared Services:                      [  OK  ]
Shutting down DSM SA Connection Service:                   [  OK  ]
Stopping Systems Management Data Engine:
Stopping dsm_sa_eventmgrd:                                 [  OK  ]
Stopping dsm_sa_datamgrd:                                  [  OK  ]
Stopping Systems Management Device Drivers:
Stopping dell_rbu:                                         [  OK  ]
Starting Systems Management Device Drivers:
Starting dell_rbu:                                         [  OK  ]
Starting ipmi driver: Already started                      [  OK  ]
Starting Systems Management Data Engine:
Starting dsm_sa_datamgrd:                                  [  OK  ]
Starting dsm_sa_eventmgrd:                                 [  OK  ]
Starting DSM SA Shared Services:                           [  OK  ]
Starting DSM SA Connection Service:                        [  OK  ]

# omreport storage controller
No controllers found

0 Kudos

Re: OMSA: No controllers found

baldolafa, what version of OMSA and what OS were you using previously, when it worked?

0 Kudos

Re: OMSA: No controllers found

Hello guys;
I faced exactly the same problem on 24th of December when I updated my DELL Poweredge 2950 server to the latest versions of kernel and everything (I’m running Centos 5.4). So I jumped also for OMSA from 5.5.0 to 6.2.0. On 25th I played around a little and I managed to have it working. In fact everything was ok from the very beginning except for the integrated RAID controller PERC 6/i. First I noticed that some configuration files from /etc/ld.so.conf.d are “DISABLED”, so I renamed them and I restarted srvadmin-services. With no effect. Then I tried to update the firmware using yum, as described here:
<ADMIN NOTE: Broken link has been removed from this post by Dell>
But it wasn’t the case, everything was up to date.
The idea of running autoconf_cim_component.sh I took from here:
<ADMIN NOTE: Broken link has been removed from this post by Dell>
Take a look at Post-Installation Configuration for Remote Enablement paragraph.

And after running this script my integrated PERC 6/i controller was seen, after restarting srvadmin-services. After that, I “DISABLED” again what it was previously “DISABLED” in /etc/ld.so.conf.d and I restarted srvsdmin-services and I verified that the controller is still detected, so I concluded that those configuration files are not important. So, basically I did nothing except running that script and I got the things working.

0 Kudos

Re: OMSA: No controllers found

We experience the same issue with CentOS 5.4 and OMSA 6.2.

I found the answer at the Dell Linux-PowerEdge mailing list: http://lists.us.dell.com/pipermail/linux-poweredge/2009-December/040829.html

After installing the package "dell_ft_install" with all its dependencies and restarting OMSA "omreport storage controller" worked again (Installing only "srvadmin-storelib-sysfs" was not enough).

So perform the following steps to fix the issue:

# yum install dell_ft_install

# srvadmin-services.sh restart


0 Kudos

Re: OMSA: No controllers found

jack987, your solution worked. In fact, I just installed srvadmin-storelib-sysfs and srvadmin-storelib-libpci (both were needed), rather than the whole dell_ft_install.

# yum install srvadmin-storelib-sysfs srvadmin-storelib-libpci

# srvadmin-services.sh restart

# omreport storage controller
Controller  PERC 5/i Integrated (Embedded)

ID                                            : 0
Status                                        : Non-Critical
Name                                          : PERC 5/i Integrated
Slot ID                                       : Embedded
State                                         : Degraded

Web-based GUI also works fine now. Thanks everyone!

0 Kudos

Re: OMSA: No controllers found

It means that trying to update the firmware using yum saved me, because it implied that

# yum install dell_ft_install

command :-)


0 Kudos

Re: OMSA: No controllers found

Clearly yum packages in dell-omsa-indep have missing dependencies. I wanted to report this as a bug, but couldn't find OMSA bug database (I guess it is not public).

Regarding dell_ft_install, I ended up installing it anyway. Omreport, when it finally started working, complained about PERC firmware being too old, so I had to upgrade it. But that's another story...

0 Kudos