R720xd: OMSA 8.3: No storage controller detected (again).

My last attempt to regain control of the controller without rebooting failed:


Now I am experiencing the problem again.

We have inserted 4 disks in order to create 2 new virtual disks. iDRAC (Version (Build 03)) can see the controller, but cannot create new virtual disks without rebooting. So I resort to using OMSA. OMSA can create the first virtual disk just fine and then loses contect to the storage controller. iDRAC still has contact to the storage controller, but doesn't reflect the new virtual disk. I soft-reboot using "racadm racreset soft" and iDRAC now reflects the new configuration. But OMSA still cannot see the controller.

I then check if racadm is able to see the controller, and it is. These commands all reflect the current configuration:

racadm raid get controllers

racadm raid get pdisks -o

racadm raid get vdisks -o

Yet OMSA cannot see the controller for some reason. I have tried restarting the 4 DSM services but this didn't help. I enabled full debug on the DSM Data Manager service and have attached the first 2 minutes of log in hope someone can point me to the culprit.

iDRAC web can see the controller and the newly created virtual disk.

OMSA 8.3 cannot see the controller.

racadm can see the controller and the newly created virtual disk.

Windows cannot see the newly created virtual disk(!)

Three questions:

Is it possible to restore controller control to OMSA without rebooting and how?

Is it possible to use racadm to create virtual disks?

How do I make the newly created disk visible to Windows (2012)?

The PERC H710P Mini (Embedded) has firmware version 21.3.2-0005 and driver version 6.805.03.00 as reported by iDRAC (Windows agrees on the driver version; can't see firmware version).

I also tried MegaCli, but it only gives return code 0x8 (or 0x1 if I use wrong command line arguments).

0 Kudos