ChopperCopper
1 Nickel

Dell Latitude 10 ST2e keeps losing date and time

My Dell Latitude 10 ST2e tablet periodically keeps losing the correct date and time.  It goes forward either one day to the maximum of 10 days. I updated the BIOS to latest hoping that would fix it but it doesn't. It appears it might have started after Windows 8.1 update but I can't be certain. Is this a known problem with this unit? Anyone else having this problem?

0 Kudos
8 Replies
herbche
1 Copper

RE: Dell Latitude 10 ST2e keeps losing date and time

I have the exact same problem. When it began, I was still under warranty. Dell tried three times to fix this and none have worked. First, they sent a technician to change the CMOS battery. Next, they had me send the unit to the factory for diagnostics and repair. Neither of those solutions lasted. I thought that perhaps there was something peculiar to the particular unit so I nagged until I got a refurbished machine as a replacement. Guess what? The problem returned. Now that I'm out of warranty, I'm not sure what, if any, support I can get.

0 Kudos
ChopperCopper
1 Nickel

RE: Dell Latitude 10 ST2e keeps losing date and time

Did you also update to Windows 8.1 and then the date problem happened?

0 Kudos
JimMac64
1 Copper

RE: Dell Latitude 10 ST2e keeps losing date and time

I'm having the same problem. It all started after the Windows 8.1 upgrade. Still haven't found a fix.
0 Kudos
daron.uk
1 Nickel

RE: Dell Latitude 10 ST2e keeps losing date and time

Same here, if I turn automatic time off and on again it corrects it for a few days but then changes to some random future time/day. I am running 8.1 however I did the update as soon as I received the tablet so I don't know if this happened before. Really annoying! Where does 8.1 retrieve it's time; bios, internet or router?
0 Kudos
Highlighted
cetservicesltd
1 Copper

RE: Dell Latitude 10 ST2e keeps losing date and time

Dell Support Confirm that Latitude 10 st2 Tablets do not support Windows 8.1 and should be reverted to Windows 8, the date and time issue does show itself until after the upgrade to 8.1. As of 22nd May 2014 there is no Fix. It's Live with it or revert to Win 8 seems to be there response.

0 Kudos
timgilley
1 Copper

RE: Dell Latitude 10 ST2e keeps losing date and time

I had the same problem and seemed to have resolved it, time will tell - ha! After a onsite tech replaced the motherboard and downloading all relevant updates I still had the problem. Two ways to fix: 1. Go to worldtimeserver.com/atomic-clock and download their atomic.exe utility. Atomic will allow you to change the update interval of the clock. The default is 604,800 seconds which is one week. Run atomic.exe and change the update to 300, 5 minutes. This has worked so far. 2. This takes a higher level of expertise and accomplishes the same thing as above. Go to command window and type regedit to start the registry editor. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpClient Double click SpecialPollInterval, change to decimal and enter 300. Also go to date and time settings and change the time server to time.nist.gov
0 Kudos
cetservicesltd
1 Copper

RE: Dell Latitude 10 ST2e keeps losing date and time

Like your thinking Tim, more of a work around; but elegant!,

We changed the registry machine on our engineering Tablet and can see no reason why it won't cover up the issue so have informed our customer base, many thanks.

0 Kudos
timgilley
1 Copper

RE: Dell Latitude 10 ST2e keeps losing date and time

Glad to help. Wish I could take credit. I found both via Google. Figured there was a registry edit and got lucky. Atomic.exe I used in the old days before the corporate networks had time servers.
0 Kudos