britepencil
1 Copper

Dell Venue 11 5130

The Venue was powered on yesterday and plugged into (original adapter and cord) I had  Netflix movie playing while I was working from my desktop.

If I recall the battery was 55% approx. Correct me if I am wrong, with the 5130 plugin  the battery should not drain. The battery icon shows plugged in and charging.

The problem is while the movie was playing the 5130 died I thought the device failed. The problem turned out to be is,  while plugged in the battery drained to 0% .

This is a serious flaw of all my devices this is the only one that cannot run on adapter power first while charging. I am really really disappointed.

Anyone else experience this problem?

0 Kudos
8 Replies
talakaci
1 Copper

RE: Dell Venue 11 5130

I have the same problem, and waiting for an answer. I also have slow charging problem. I tried to charge after I shut down, but still same problem. Some people says it might be an software problem, but while it was shutdown, how is it possible? It seems that's a common problem. If it's so, I hope Dell brings a good solution.
0 Kudos
britepencil
1 Copper

RE: Dell Venue 11 5130

once logged into the services wind F12 on boot up error messages about the adapter was only a 3W adapter but indicated that a 23 watt adapter is required hence the battery drain to zero% when plugged in...very odd.

Dell support was not a lot of help other than to RMA, I fiddled with the connector to the Venue power port and presto I got the system to recognize the full adapter as a 23W no errors and charging normally

With any port that has constant use of push in / pull out will have ware tear but not after a couple of weeks.....My advice is to make sure the cord is well seated into the Venue power port..see if that resolves the recharge rate

0 Kudos

RE: Dell Venue 11 5130

Yes. I have had the same problem. Plugged in and charging, yet not charging and saying my adapter is only a 3w, when it has the original adapter plugged in. Discouraging to say the least, since I have had to send it back to be serviced twice in a month!! The motherboard died, then they sent it back without the Windows product key. *sigh*

0 Kudos
neverlandradio
1 Copper

RE: Dell Venue 11 5130

I also have the problem since yesterday. Tablet only charges with 3W instead of 23. I have the Tablet for a little over 6 month and so far i did not have the problem.

Tried to jiggle the connector did not help. Also installing the new Bios Version 9 and reinstalling most of the drivers did not have any effect. i changed the settings in the power managers, also no effect.

Where does this come from? What else can I do? It is the third time I have major issues with the dell tablet. It also is the second modell I have. I expect dell to give provide a solution or I will make them give me my money back.

0 Kudos
talakaci
1 Copper

RE: Dell Venue 11 5130

They changed the charger unit of motherboard and problem was solved. But after two months, I have that issue, again. This week, I am going to send it for repair, againnnn. Also, I will extent the warranty for another one year. This seems a common problem, and Dell couldn't handle it. I'm done with Dell, never buy anything again. I am not a law expert, but there should be a legal way to refund.

0 Kudos
neverlandradio
1 Copper

RE: Dell Venue 11 5130

Ok I'll try to contact the support tomorrow.

0 Kudos
standds
1 Copper

RE: Dell Venue 11 5130

Lost all faith in dell products.  spent over $50,000 over the past two years with only 60% of the products work properly!

0 Kudos
Pat Fahey
1 Copper

RE: Dell Venue 11 5130

I notice that Dell Representatives quite often jump in with answers.

It seems that they have no good answer for the charging problems.

I have 5 of these units with another 7 on order, i am wondering if I should just return them and move to a surface 3.

My faith in Dell would be helped if the techs would respond to this issue.

0 Kudos