Tablets & Mobile Devices

Last reply by 06-08-2016 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Trying Ubuntu 16.04 on a Dell Venue 11 Pro 7140 - not working very well

I've been running a daily build of Ubuntu 16.04 (which is not yet released) on my Dell Venue 11 Pro 7140 for a few days. In general, it's very stable, except for an occasional pop-up, "Sorry, Ubuntu 16.04 has experienced an internal error", which doesn't have any other ill effects that I can discern.

I had hoped that Ubuntu's sleep behavior would be better than Windows 8.1, but it's just as bad - the only usable sleep mode is hibernate. This tablet was released with broken operating system support for sleep, and now, a year later, it's STILL broken in Windows 8.1 and Linux. Under Windows, my 7140 still burns 9% of its battery per hour when "asleep," even running the latest drivers and updates.

Used with a physical keybard and mouse or touchpad, Ubuntu 16.04 works very well on the 7140. As a pure tablet, without a physical keyboard or pointing device, using just the touch screen for input, it has a lot of problems. I would be happy if I could use just 3 programs: firefox, thunderbird, and vlc. Of the three, vlc works perfectly, firefox is marginally usable (with some contriving), but thunderbird is not usable for me.

One glaring problem with the touch screen in Ubuntu 16.04 is the inability to right-click. "settings / universal access / pointing and clicking / simulated secondary click - ON" is supposed to simulate a right-click with a long finger press, but it works only in some programs, and then only intermittently. The built-in on-screen keyboard, "onboard", can simulate mouse button clicks, but it's cumbersome - it requires several clicks, and the keyboard covers a significant fraction of the screen when active.

The default text editor, gedit, shows what's possible on the touch screen in Ubuntu 16.04 - it implements scrolling, text selection, and right-click, all with 1-finger gestures, and they work consistently and feel good.

With firefox, the "grab and drag" extension gets you 1-finger scrolling, but it only works if you click a non-clickable area of the screen, it breaks text selection, and momentum doesn't work. I make heavy use of tabs in firefox, which requires right-clicking. Unfortunately, the only way to right-click in firefox is with the cumbersome on-screen keyboard.

With thunderbird, there is no reasonable way to scroll through a mailbox with many messages or to scroll through a single large message. The scroll bar controls are tiny, and moving them the tiniest bit jumps too far.

If you do a web search, you find many suggestions for making Ubuntu usable on a touch screen - ginn, synclient, xswipe, touchegg, mtrack, easystroke, etc. You also find many users saying they tried one or another and they didn't work. I've tried a few of these, to no avail, but I don't have time to continue trying every dodgy recommendation I find on the web.

Currently, my most severe pain point is scrolling in thunderbird. If anyone is successfully using thunderbird with a touch screen in Ubuntu, I'd love to hear how you're doing it. Or, if there is an alternative email client that is reliable, usable on a touch screen, and in ubuntu repos, I'd also love to hear about it.

Finally, one last huge problem - the boot environment has no on-screen keyboard, so there's no way to use full disk encryption in Ubuntu without a physical keyboard.

Replies (19)
2 Bronze
2 Bronze

I've found that the evolution email client handles the touch screen much better than thunderbird, so my biggest pain point has been relieved. Ubuntu 16.04 is now usable (though still far from perfect) for my modest requirements.

There's also one user report that sleep works with kernel version 4.4.1, which, presumably, will make its way to ubuntu 16.04 before too long.

2 Bronze
2 Bronze

Hi,


what did you do to make the touchscreen work? Did it work out of the box?

I just installed 16.04 and the touchscreen does neither work with kernel 4.4.0-15 nor 4.4.6-040406 (from kernel.ubuntu.com/.../v4.4.6-wily).

2 Bronze
2 Bronze

It just worked out of the box. I didn't need to do anything special to enable the touch screen to work.

I have the Dell "slim" tablet keyboard, and I used it during installation, but I'm pretty sure the touch screen was working the whole time.

Of course, when say "working", I mean the hardware and system software appear to be working perfectly, but application support is very poor. And the touch screen is useless for entering a password if you're using full-disk encryption, since there is no on-screen keyboard.

I'm currently running kernel 4.4.0-14, which I got through a routine software update. I have no usable sleep modes, but one arch linux user reported that the 7140 can sleep successfully with kernel 4.4.1. I'm waiting for it to show up in a software update.

I will say the system is very stable. Since it can't sleep, I just keep it plugged in and powered on 24/7, and it's never crashed or acted flaky.

2 Bronze
2 Bronze

Thanks for the prompt response and good to hear that it worked out of the box for you. Let's see whether I can find the problem with my installation.


Edit: Taking todays image from http://cdimage.ubuntu.com/daily-live/20160323/ solved the touchscreen issue.

2 Bronze
2 Bronze

Congrats on getting it working. Please post if you figure out any tricks for making it more usable as a tablet.

I'm getting by with firefox, evolution, and vlc, mediated by onboard.

An example of the UI problems is opening a link in a new tab in firefox. With the physical keyboard/trackpad attached, I can middle-click or right-click on a link, to open it in a new tab. On the touch-screen, I have to:

  1. tap the onboard icon, which i have locked to the launcher, which i have permanently visible. this brings up the on-screen keyboard, which covers a good bit of the screen.
  2. scroll the page, if the link i want has been covered by the keyboard. this works because i'm using the "grab and drag" firefox extension.
  3. tap onboard's middle mouse button.
  4. tap the link i want to open.
  5. tap onboard's button, to hide it again.

running windows on the same tablet, i can long-press to simulate a right-click. i can't do that on ubuntu.

2 Bronze
2 Bronze

A couple of quick updates:

I mis-spoke when I said "I have no usable sleep modes." I had written in my original post that hibernate does work, and I just verified that again today.

After a recent update, the firefox "open link in new tab" extension now works, so I no longer have to go through the laborious procedure with the on-screen keyboard.

One step at a time...

2 Bronze
2 Bronze

I tried the sleep mode configuration described at https://bbs.archlinux.org/viewtopic.php?pid=1601365#p1601365 and it appears to work.

This page http://www.studioteabag.com/science/dell-venue-pro-linux/ was quite useful for me in figuring out how to make the stylus work when the screen is rotated. As auto rotation doesn't work, I wrote the following script to toggle screen rotation:

#!/bin/sh
# determine whether screen is already rotated
xrandr --current | grep primary | grep "left ("
if [ $? -eq 1 ];
then
  xrandr -o left
  # rotate stylus driver
  xinput set-prop 13 "Evdev Axis Inversion" 1, 0
  xinput set-prop 13 "Evdev Axes Swap" 1
else
  xrandr -o normal
  # un-rotate stylus driver
  xinput set-prop 13 "Evdev Axis Inversion" 0, 0
  xinput set-prop 13 "Evdev Axes Swap" 0
fi

 

With the launcher that I created for this script, I can much better use the device as a tablet.

2 Bronze
2 Bronze

If you own a stylus you can use

xinput set-button-map "SYNA7500:00 06CB:780E Pen" 1 3 2 4 5

to enable a right-click on the lower stylus button (click the button when hovering)

2 Bronze
2 Bronze

I tried the sleep mode configuration described at https://bbs.archlinux.org/viewtopic.php?pid=1601365#p1601365 and it appears to work.

Freeze hasn't worked for me in the past. Just now, I ran Software Updater to bring my 7140 fully up to date, then I tried "echo freeze > /sys/power/state" (running as root).

I get into the state where the screen is off, and tapping the on-screen button elicits a brief buzz, but no other observable behavior. I have to hold the power button down for 20 sec, to power off, then hold it on for a few secs, to power on again.

In my case, "Freeze" is aptly named.

Top Contributor
Latest Solutions