Tablets & Mobile Devices

Last reply by 06-08-2016 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Trying Ubuntu 16.04 on a Dell Venue 11 Pro 7140 - not working very well

I've been running a daily build of Ubuntu 16.04 (which is not yet released) on my Dell Venue 11 Pro 7140 for a few days. In general, it's very stable, except for an occasional pop-up, "Sorry, Ubuntu 16.04 has experienced an internal error", which doesn't have any other ill effects that I can discern.

I had hoped that Ubuntu's sleep behavior would be better than Windows 8.1, but it's just as bad - the only usable sleep mode is hibernate. This tablet was released with broken operating system support for sleep, and now, a year later, it's STILL broken in Windows 8.1 and Linux. Under Windows, my 7140 still burns 9% of its battery per hour when "asleep," even running the latest drivers and updates.

Used with a physical keybard and mouse or touchpad, Ubuntu 16.04 works very well on the 7140. As a pure tablet, without a physical keyboard or pointing device, using just the touch screen for input, it has a lot of problems. I would be happy if I could use just 3 programs: firefox, thunderbird, and vlc. Of the three, vlc works perfectly, firefox is marginally usable (with some contriving), but thunderbird is not usable for me.

One glaring problem with the touch screen in Ubuntu 16.04 is the inability to right-click. "settings / universal access / pointing and clicking / simulated secondary click - ON" is supposed to simulate a right-click with a long finger press, but it works only in some programs, and then only intermittently. The built-in on-screen keyboard, "onboard", can simulate mouse button clicks, but it's cumbersome - it requires several clicks, and the keyboard covers a significant fraction of the screen when active.

The default text editor, gedit, shows what's possible on the touch screen in Ubuntu 16.04 - it implements scrolling, text selection, and right-click, all with 1-finger gestures, and they work consistently and feel good.

With firefox, the "grab and drag" extension gets you 1-finger scrolling, but it only works if you click a non-clickable area of the screen, it breaks text selection, and momentum doesn't work. I make heavy use of tabs in firefox, which requires right-clicking. Unfortunately, the only way to right-click in firefox is with the cumbersome on-screen keyboard.

With thunderbird, there is no reasonable way to scroll through a mailbox with many messages or to scroll through a single large message. The scroll bar controls are tiny, and moving them the tiniest bit jumps too far.

If you do a web search, you find many suggestions for making Ubuntu usable on a touch screen - ginn, synclient, xswipe, touchegg, mtrack, easystroke, etc. You also find many users saying they tried one or another and they didn't work. I've tried a few of these, to no avail, but I don't have time to continue trying every dodgy recommendation I find on the web.

Currently, my most severe pain point is scrolling in thunderbird. If anyone is successfully using thunderbird with a touch screen in Ubuntu, I'd love to hear how you're doing it. Or, if there is an alternative email client that is reliable, usable on a touch screen, and in ubuntu repos, I'd also love to hear about it.

Finally, one last huge problem - the boot environment has no on-screen keyboard, so there's no way to use full disk encryption in Ubuntu without a physical keyboard.

Replies (19)
2 Bronze
2 Bronze

BTW, the author of the thread you linked to is the same person who reported that freeze works as of kernel 4.4.1:

i have kernel 4.4.0-15.

do you have freeze working on a 4.4.0 kernel?

2 Bronze
2 Bronze

I am also on kernel 4.4.0-15. When creating the /etc/systemd/sleep.conf the sleep/resume works for me using the slim keyboard to wake up the tablet. The problem is that none of the keys/buttons of the tablet can wake it up. Hope that this will be resolved when the power button will eventually be recognised.

2 Bronze
2 Bronze

I just upgraded from 15.10 to 16.04.  I had the same problem in that my touchscreen stopped working completely (even though it worked perfectly in 15.04).

I "upgraded" to Mainline kernel 4.6-rc4-wily and it's working again.  I'm unsure if the "wily" tag is special.  Maybe there's something about wily kernels that don't work with xenial.

On the booting with full disc encryption, I have an open bug for that here.  Please add yourself to the "I'm affected" list at the top!  Thanks!

2 Bronze
2 Bronze

I'm testing 16.04 on a Venue 11 Pro 7139 and having serious issus with the touch-screen. When I boot the live system it works very well but after installation it is dead. The only difference between live and installed system I could find is the recording of evbug messages in /var/log/kern.log whenever I use the touchpad. This does not happen in the live system.

Edit: I installed the Mainline kernel 4.5.2 and it's working now.

2 Bronze
2 Bronze

I just did a fresh install of the official 16.04 desktop system on my 7140 via liveUSB.

The installation wizard was unable to connect to wifi, for downloading updates and 3rd-party software during installation. Fortunately, there is an easy work-around.

After booting the liveUSB, I choose “try ubuntu”, so I can increase the size of my boot partition, as described here (i use "2048 2048 2048"):

To get wifi to work:

  settings / network - select your access point

  dismiss the wifi connection dialog that appears

  click the right arrow next to your access point's name, then settings / security

  enter your wifi password, click "save", then click "connect"

Then start the install wizard, by double-clicking the "install ubuntu" icon on the desktop.

Running the released 16.04, my 7140 is working just as described in the other posts in this thread.

I'm pretty happy with firefox on the touchscreen, since I've installed the "grab and drag", "open bookmarks in new tab", and "open link in new tab" extensions and now have customized the "grab and drag" preferences to my liking. Evolution and vlc continue to work well.

Freeze works, but my 7140 can't wake up without a physical keyboard, as Asvin reported above.

One other problem: the integrated microSD card slot doesn't work. Here's a work-around, based on

  create /etc/modprobe.d/sdhci.conf, containing a single line:

      options sdhci debug_quirks2="0x4"

  update-initramfs -u -k all

2 Bronze
2 Bronze

Hey guys,

Any major problems left with this device wthh 16.04 + a newer kernel?

Do the headphones and speakers work now?

What about the freeze state? How is that working out for you?



2 Bronze
2 Bronze

I just tried the kernel patch (Bug 102281) from and managed to get the power button working :emotion-2:

This is what I did (if I remember correctly):

- download kernel 4.4.6 from

- compiled kernel as described in

 (note: compilation took me 1.5-2h and I got impatient in the last steps and aborted the process after the two .deb files below where ready)

- installed the kernel by

sudo dpkg -i linux-headers-4.4.6-custom_4.4.6-custom-1_amd64.deb
sudo dpkg -i linux-image-4.4.6-custom_4.4.6-custom-1_amd64.deb

With this kernel I can use the power button to wake from suspend without physical keyboard.

2 Bronze
2 Bronze

Although I am pretty happy with the device in laptop mode, I think Ubuntu still needs quite some improvement in tablet mode (i.e. without physical keyboard).

So I tested Remix OS following the installation instructions at (had to copy all files to the /remix folder, though) and now I can dual boot Ubuntu or Android depending on my use case. Touch support & stylus work out of the box in Remix OS, but power button and rotation does not. Furthermore, I don't know how I can tell Remix OS that I am using a (physical) QWERTZ keyboard. Anyhow at the moment I prefer touch use on Remix to Ubuntu.

I configured grub2 to remember my last boot choice following and so I can reboot from Remix into Remix without the keyboard attached.

2 Bronze
2 Bronze

Rotation and even auto-rotate works in Remix OS after modifying system.img and unchecking forced landscape in the experimental settings.

To modify system.img in Ubuntu I used the following commands (written down from memory):

cp /remix/system.img .
sudo mv /remix/system.img /remix/system.img.bak
mkdir tmp
sudo chmod 0644 system.img
sudo mount -o loop,rw -t ext4 system.img tmp/
gksudo gedit tmp/build.prop
# change "" to "" and save
umount tmp
rm -r tmp
sudo cp system.img /remix/system.img

Unfortunately, the stylus coordinates are messed up in portrait mode.

2 Bronze
2 Bronze

It is possible to select the grub2 boot menu without physical keyboard using volume up/volume down and windows button. However, it requires to recompile grub similar to how it is described at

The main difference is that buttons are differently mapped:

- Volume Up: GRUB_TERM_KEY_F1
- Volume Down: GRUB_TERM_KEY_F2
- Windows Button: GRUB_TERM_KEY_F5

Thus, the respective cases should be added to menu.c of the grub source.

Latest Solutions
Top Contributor