Highlighted
3 Silver

Unable to disable savedev from default pool

Jump to solution


Hi Guys,

I am trying to create a DSE pool in VMAXe 10K. I have created a pool of type rdfa_dse. I have around 30 savedev's that are in default_pool, I want to move them to the DSE pool.

The procedure im following is to first disable the device from default pool then add them to dse pool.

symcli is not allowing me to disable the devices in default pool, below is the error, Any suggestions are welcome

C:\>symconfigure -sid 73 -cmd "disable dev 010B in pool DEFAULT_POOL type=SAVEDEV;" preview

Execute a symconfigure operation for symmetrix 'XXXXXXXXXX' (y/) ? y

A Configuration Change operation is in progress. Please wait...

    Establishing a configuration change session...............Established.

    Error occurred while Defining change number 1:
    The requested feature is not supported for this Enginuity or SYMAPI version
    Device 010B generated the failure

    Terminating the configuration change session..............Done.

The configuration change session has failed.

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
4 Beryllium

Re: Unable to disable savedev from default pool

Jump to solution

Ok, the SAV devices are well laid out, but I would rather see one on every disk.  They are on 60 out of 116 active disks.

Not sure why you are thinking of enabling DSE.  Again I would get your local account team involved in this.  There are cases where enabling DSE won't help.  RDF/A will still drop and the time to recover will be longer.  There are also cases where it will work great, and keep RDF/A from dropping.  Someone will need to look at your use case and workload to see which bucket you fall into.

View solution in original post

0 Kudos
21 Replies
Highlighted
3 Argentum

Re: Unable to disable savedev from default pool

Jump to solution

Hi,

What code level are you running?  Can you check if the devices are already disabled? I tried this on my test array running 5876.251.161 and got the same message when trying to disable SAVE devs in the default pool that were already disabled.  Also got same message when trying to enable them in the default pool, so if enabling them is blocked, yours may not be enabled either.

I was able to move them to a DSE pool, either in enabled or disabled state, and then change state to enabled/disabled from inside the DSE pool.

Mike

0 Kudos
Highlighted
4 Beryllium

Re: Unable to disable savedev from default pool

Jump to solution

First, I thought SAV devices were not supported in a 10K.

Second, a DSE pool must be properly laid out on the backend to function properly.  Just making some DSE devices and enabling DSE may make RDF/A worse, not better.

Please contact your local EMC SPEED guru for assistance in configuring a DSE pool.

0 Kudos
Highlighted
3 Silver

Re: Unable to disable savedev from default pool

Jump to solution

HI Quincy,

I haven't created these SAVEDEV's. These were created by EMC when we bought the VMAX and were never used. Now Im trying to use them. Im not sure if SAVEDEV's are supported in VMAX 10K but if i can see them then they should be supported.

0 Kudos
Highlighted
3 Silver

Re: Unable to disable savedev from default pool

Jump to solution

I did find a workaround though but it goes against what Quincy just said to which I agree.

If I create new SAVEDEV with attribute "SAVEDEV in pool DSE_R1_01" then it works, but then Im even unable to delete the existing SAVEDEV's created by EMC and secondly the performance part of creating SAVEDEV manually by myself.

0 Kudos
Highlighted
4 Beryllium

Re: Unable to disable savedev from default pool

Jump to solution

If you want to send me a private message with the serial # of your system, I could take a look at the layout of your SAV devices and see if they look like good candidates for DSE.

DSE is good for some use cases where there is a short burst of workload or times where the links go down for short periods of time.  It won't help for workloads that go above the limits of your system for long periods of time, or long link outages.

Highlighted
3 Silver

Re: Unable to disable savedev from default pool

Jump to solution

Sure Quincy, Let me know your mail address.

0 Kudos
Highlighted
4 Beryllium

Re: Unable to disable savedev from default pool

Jump to solution

You should be able to click on my "handle" and send me a private message.  I can't seem to send you a private message here as it seems you have blocked that feature

0 Kudos
Highlighted
3 Silver

Re: Unable to disable savedev from default pool

Jump to solution

Cant seem to find the option for private message. When I hover the mouse over your name it says email is private

0 Kudos
Highlighted
3 Argentum

Re: Unable to disable savedev from default pool

Jump to solution

You have to both be "following" each other on ECN in order to send private messages FYI... to follow someone, click on their name/icon to go to their profile; from there, click the follow button on the top right of the page.