Highlighted
candace_cowan
1 Nickel

VMAX 200K What is correct volume expansion command syntax for SE 8.2v?

Jump to solution

I would like to use CLI to expand some volumes (TDEV) however I cannot get the syntax correct.  I have the following support doc below however syntax fail for me.  I am using SE v8.2

Symmetrix Command Line Interface (SYMCLI) Version V8.2.0.0 (Edit Level: 2153)

built with SYMAPI Version V8.2.0.0 (Edit Level: 2153)

I've tried the syntax several ways but still fails.  Any advice on correct command?

C:\windows\system32>symdev modify 001DF -sid 515 -cap 64 -nop -tdev

One or more arguments are invalid

C:\windows\system32>symdev -sid 515 modify -tdev 001DF -cap 64gb prepare -nop

'64gb': Invalid device capacity.

C:\windows\system32>symdev -sid 515 modify -tdev 001DF -cap 64 prepare -nop

Invalid number of keywords.

EMC Support document with volume expansion directions:

https://support.emc.com/kb/466737



VMAX3 5977.691.684 Thin device expansion support:

  • Expanding an existing Thin device is supported with HYPERMAX OS 5977.691.684 and Solutions Enabler and Unisphere 8.1.0
  • Volume expansion can be performed only for HYPERMAX OS 5977, or higher.
  • Volumes can be expanded up to, and including, a size of 64 TB.
  • Volume expansion cannot be performed if any of the following operations are currently being carried out on the volume:
    • free all
    • reclaim
    • allocation
  • Restrictions apply if the volume:
    • is a gatekeeper
    • is an ACLX volume
    • has Celerra FBA emulation
    • is an AS400 volume
    • is FTS encapsulated
    • has a SnapVX session defined, or is being replicated
       

Solutions Enabler:

  • symdev -sid <SymmID> [-noprompt]
    modify  tdev -cap <#> [-captype <cyl|mb|gb|tb>]
    -devs <<SymDevStart>:<SymDevEnd> | <SymDevName>
    [,<<SymDevStart>:<SymDevEnd> | <SymDevName>>...]>
     
    Example:
    symdev modify 1fe0 -sid 005 -cap 20000 -nop -tdev
    Modify operation succeeded for devices: 1fe0

Please note the -cap in the command above refers to the size you want the device expanded to. Not the extra amount of space. So enter the amount you want as the final size for the device.

Labels (1)
1 Solution

Accepted Solutions
candace_cowan
1 Nickel

Re: VMAX 200K What is correct volume expansion command syntax for SE 8.2v?

Jump to solution

Hello Allen Ward

Thank you for your response, which lead me down the correct path!  I tried the way you suggested but appeared it was still wrong order, however I modified your example a little and now was successful!

C:\windows\system32>symdev -sid 515 modify tdev 001DF -cap 64 -captype gb -nop

'tdev': Invalid device name.

CORRECTED COMMAND:

C:\windows\system32>symdev modify 001DF -sid 515 -cap 64 -captype gb -nop -tdev

Modify devices operation succeeded.

0 Kudos
5 Replies
8 Krypton

Re: VMAX 200K What is correct volume expansion command syntax for SE 8.2v?

Jump to solution

In the first example you appear to have a dash in front of the "tdev" which does not appear in the format. In the second example you are trying to define a capacity type without the "-captype" parameter. Both the third and fourth examples include "prepare" as if you were running a symconfigure command but you are running symdev.

Try

symdev -sid 515 modify 001df tdev -cap 64 -captype gb -nop

0 Kudos
8 Krypton

Re: VMAX 200K What is correct volume expansion command syntax for SE 8.2v?

Jump to solution

Hmmmm.... looks like the '-tdev" is correct and does require the dash.

I can't seem to find any reference (quickly) on what the default is if you don't set a -captype, so maybe it defaults to something that didn't work. Try it with the captype defined and the dash still in front of the tdev

candace_cowan
1 Nickel

Re: VMAX 200K What is correct volume expansion command syntax for SE 8.2v?

Jump to solution

Hello Allen Ward

Thank you for your response, which lead me down the correct path!  I tried the way you suggested but appeared it was still wrong order, however I modified your example a little and now was successful!

C:\windows\system32>symdev -sid 515 modify tdev 001DF -cap 64 -captype gb -nop

'tdev': Invalid device name.

CORRECTED COMMAND:

C:\windows\system32>symdev modify 001DF -sid 515 -cap 64 -captype gb -nop -tdev

Modify devices operation succeeded.

0 Kudos
8 Krypton

Re: VMAX 200K What is correct volume expansion command syntax for SE 8.2v?

Jump to solution

This should work:

symdev -sid <sid> modify <dev> -tdev -cap <capacity> -captype <mb|gb|tb>

8 Krypton

Re: VMAX 200K What is correct volume expansion command syntax for SE 8.2v?

Jump to solution

I'm glad you got it. lf before I suggest, but I could try this out on. Looks like my error was in misinterpreting the "-tdev" from identifying a specific tdev where it really just identifies that the device type being acted on is a tdev.

This is one of my beefs with the Solutions Enabler CLI suite. There are times where different commands use the same argument in a different way. It's not as bad as it used to be, but can still lead to confusion. In this particular case it also bothers me that it seems to show the "-captype" as optional, but if you don't HAVE to include it that implies that one of the values is the default... but the documentation doesn't show what that default is (if it exists at all).

0 Kudos