Highlighted
kjstech
3 Argentium

EMC VSI vSphere plugin returns "Failed to obtain the NFS details..."

Jump to solution

Greetings,


Our EMC VSI vSphere plugin returns "Failed to obtain the NFS details for the selected datastore.  Please see the log file for additional details."

We are using vSphere 5.0 with the latest updates.  There is no issue with this tab on a datastore that is on a Celerra NX4.  But if its on a datastore that is on a VNX5200, we get this error.


This used to work.  Any idea what could have happened/  Also what log file are they talking about?  Could the plugin be updated so the word "log" is a hyperlink that takes you to the actual log?  A little help here?

Labels (2)
0 Kudos
1 Solution

Accepted Solutions
kjstech
3 Argentium

Re: EMC VSI vSphere plugin returns "Failed to obtain the NFS details..."

Jump to solution

I went to the home tab in vSphere Cleint then EMC at the bottom under Solutions and Applications.  Went to VNX systems on the left side, checked my VNX5200 and did remove system.  Did an add and entered the IP address for SPA and SPB, global for scope and nasadmin for username, then put in the nasadmin password.  Control station I put in the host name and checked use same credentials from block.

It gave me an error "Failed to update the storage details and configuration for the VNX systems listed.  Error = Invalid parameter passed for the array ID list.".  However the array appeared in the list anyway with a File OE version number, 2 datamovers and 3 file systems listed, along with the serial number.

Now the EMC VSI tab on each file system shows data.  There is still an error about an invalid parameter,but that is only if you go to the area to setup the VNX systems.  I think its benign error because the data about the filesystems come back ok in vSphere.

0 Kudos
1 Reply
kjstech
3 Argentium

Re: EMC VSI vSphere plugin returns "Failed to obtain the NFS details..."

Jump to solution

I went to the home tab in vSphere Cleint then EMC at the bottom under Solutions and Applications.  Went to VNX systems on the left side, checked my VNX5200 and did remove system.  Did an add and entered the IP address for SPA and SPB, global for scope and nasadmin for username, then put in the nasadmin password.  Control station I put in the host name and checked use same credentials from block.

It gave me an error "Failed to update the storage details and configuration for the VNX systems listed.  Error = Invalid parameter passed for the array ID list.".  However the array appeared in the list anyway with a File OE version number, 2 datamovers and 3 file systems listed, along with the serial number.

Now the EMC VSI tab on each file system shows data.  There is still an error about an invalid parameter,but that is only if you go to the area to setup the VNX systems.  I think its benign error because the data about the filesystems come back ok in vSphere.

0 Kudos