Highlighted
Dmitry_Z
1 Copper

Has anyone had any success with unmap blocks with RDM thin LUN on EMC VNX 5300

Hello Everybody,

I've been fighting with this 2 days:

My environment:

  • EMC VNX 5300 running latest OE from March 2015
  • VMWare 5.5 Update 2. Four nodes on top of HP BL 460 Gen 8 blades
  • Thin LUN provisioned on EMC and presented as RDM (physical) to vm running RedHat 6.5

I know that unmap is supported, at least when I provision data store, create some eager zeroed vmdk, then delete it

and then run

esxcli storage vmfs unmap -l DataStoreName

I can see space being reclaimed on the EMC Lun.

Now I'm trying to do the same with RDM (physical).

Per RedHat starting from RedHat 6.0(3) they support discard on ext4

What is "Thin Provisioning" (of storage) and how does it relate to RHEL6? - Red Hat Customer Portal

https://access.redhat.com/solutions/44477

So I've tried with just a block device

mkfs.ext4 -E discard /dev/sdb

mount -o discard /dev/sdb /mnt

And also tried putting fs on top of lvm

pvcreate /dev/sdb

vgcreate TestVG /dev/sdb

lvcreate -l 100%FREE -n TestLV TestVG

mkfs.ext4 - E discard /dev/TestVG/TestLV

mount -o discard /dev/mapper/TestVG/TestLV /mnt

In both cases it doesn't look like discard is actually working.

Reading RedHat docs it looks like it's supposed to use UNMAP when mounted with -o discard.

And since I provisioned it in VMWare as RDM - it's supposed to pass all the SCSI commands to the underlying LUN.

However I'm not seeing this happening.

When I copy some 4GB iso to this file system, then create several copies of it and then delete it - I see absolutely no change on the LUN in terms of reclaiming space.

It only grows in size.

I'm really lost now.

My next steps would be installing RedHat 6.5 on the bare metal and checking if this issue is still there.

Could it be that HBA driver is blocking some commands en route to EMC?

Anyway, I'm going to try on the bare metal:

RedHat 6.5

RedHat 7

FC 21

OEL

Will report back results.

Labels (2)
Tags (2)
0 Kudos