Highlighted
needmorstuff
6 Indium

VNX5500, Cisco UCS, Powerpath - vaai not working as expected

Hi all,

We have recently deployed a vnx5500, cisco ucs blades and esxi 4.1.

I installed powerpath and licensed correctly.

Now my problem.. a storage vmotion operation with vaai enabled has a lower command number than with it disabled but nothing as low as it should be. Also if that wasnt bad enough it takes 3 times as long to complete the storage vmotion operation.

Block sizes are all the same, no rdm's in use, no snapshots, vm powered off.

vnx5500 is on 05.31.000.5.008

vaai disabled
8000 cmds
280 mbwrtns
time taken to migrate vm - 3 mins 16 seconds

vaai enabled
2100 cmds
67 mbwrts
time taken to migrate vm - 8 mins 25 seconds

Labels (1)
0 Kudos
5 Replies
itzikr
6 Indium

Re: VNX5500, Cisco UCS, Powerpath - vaai not working as expected

Hi

I would encourage you to watch a webcast Chad delivered 2 weeks ago:

http://virtualgeek.typepad.com/virtual_geek/2011/07/3-pieces-of-bad-news-and-a-deep-dive-into-apd.html

Thanks!

Itzik Reich

vSpecialist Technical, EMEA South

+972 54 6757171

ב-Jul 15, 2011, בשעה 11:42 AM, "needmorstuff" <emc-community-network@emc.com<mailto:emc-community-network@emc.com>> כתב/ה:

EMC Community Network<https://community.emc.com/index.jspa>

VNX5500, Cisco UCS, Powerpath - vaai not working as expected

created by needmorstuff<https://community.emc.com/people/needmorstuff> in Everything VMware At EMC - View the full discussion<https://community.emc.com/message/555435#555435

needmorstuff
6 Indium

Re: VNX5500, Cisco UCS, Powerpath - vaai not working as expected

so from that I see vaai doesnt work and powerpath may cause a psod.. did I miss anything?

0 Kudos
needmorstuff
6 Indium

Re: VNX5500, Cisco UCS, Powerpath - vaai not working as expected

Got this in my messages log while performing storage vmotion...

Jul 15 10:32:17 vmkernel: 0:01:13:49.340 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7e011" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
Jul 15 10:32:17 vmkernel: 0:01:13:49.340 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7e011" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
Jul 15 10:32:17 vmkernel: 0:01:13:49.340 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7e011" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
Jul 15 10:32:17 vmkernel: 0:01:13:49.340 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7e011" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
Jul 15 10:32:17 vmkernel: 0:01:13:49.340 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7e011" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
Jul 15 10:32:17 vmkernel: 0:01:13:49.340 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7e011" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
Jul 15 10:32:17 vmkernel: 0:01:13:49.625 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7e011" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
Jul 15 10:32:17 vmkernel: 0:01:13:49.625 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7e011" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
Jul 15 10:32:17 vmkernel: 0:01:13:49.625 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7e011" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
Jul 15 10:32:17 vmkernel: 0:01:13:49.625 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7e011" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
Jul 15 10:32:17 vmkernel: 0:01:13:49.625 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7e011" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
Jul 15 10:32:17 vmkernel: 0:01:13:49.625 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7e011" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
Jul 15 10:32:17 vmkernel: 0:01:13:49.625 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7e011" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
Jul 15 10:32:17 vmkernel: 0:01:13:49.625 cpu3:4099)ScsiDeviceIO: 1672: Command 0xfe to device "naa.600601601b302c00aa052753faa7

0 Kudos
itzikr
6 Indium

Re: VNX5500, Cisco UCS, Powerpath - vaai not working as expected

Not Exactly,

1. You can safely install PowerPath/VE. there is an hotfix for this (RARE) issue, so if it happens at your site, please

open an EMC sr and quote Service Alert 1094 .

2. VAAI is a FAMILY of features (3 in vSphere 4.1), You can safely enable "Accelerated

Locking" (VMFS3.HardwareAcceleratedLocking) - this is the feature that prevent a lun locking everytime there is a

VM metadate update.

the other 2 VAAI features: Hardware-Accelerated Copy & Hardware-Accelerated Zero can be enabled as well

they will: Reduce the frontend/SAN/host traffice but MAY not always reduce clock time to complete the task.

Itzik Reich

vSpecialist Technical, EMEA

0 Kudos
needmorstuff
6 Indium

Re: VNX5500, Cisco UCS, Powerpath - vaai not working as expected

It does reduce by 50% the fornt end commands on the esx host  but increases the time taken drastically to complete the operation - this is not the calimed fucntionality of decreasing front end commands and decreasing the time taken.

If this is functioning as expected then we have been misold.

For the record, I trialled  a HDS AMS2500 before the EMC san and the front end commands were in the hundreds not the thousands I am seeing now.. so it still makes me think its not working,

0 Kudos