Anonymous
Not applicable

Boot from San

Hi,

I have a customer and he has the following question:

If I have a lun and it's id is 20 but I would like to have my host see it as lun id 0 how would I configure this so I can boot from this lun?

Can we ask cutomer to follow the below mentioned Steps :

1. boot the host and go into bios for the hba card (keep a close eye when the system boots and you will get the key combination to enter hba setup before the OS boots.
2. enable the bios or boot function in the setup.
3. zone the hba to the array ports.
4. the hba should now be visible on array connectivity status.
5. register the hba records for the host.
6. assign a lun to the host.
7. the lun should now be visible in the hba setup.
8. save the settings and now start OS setup.
9. older OSs may need drivers for the hba to be loaded during setup. once done the lun should be visible to the host during setup and then you can complete the installation

Kindly suggest.

Regards

Vandy

0 Kudos
3 Replies
2 Iron

Re: Boot from San

Hi Vandy,

Please mention which Array and Operting System that customer want to configure with SAN Boot.

If its CLARiiON, while adding the LUN to the Storage Group you can assign HLU (Host LUN Number) as '0'. If its Symm then while masking, you can use Set LUN Offset feature to make the LUN visible to the host as '0".

First Of All, the HBA card should support Boot from SAN. Please check the same and if required, upgrade the firmware.

Windows Host :

Enter the BIOS, Enable SAN boot on the HBA card (Please check the HBA Manufacturer's Manaul).

Change the boot sequence.

Start Installing the OS, you may have to press F6 and load the driver for HBA card during installation.

Solaris Host:

Go to OK prompt, probe the SCSI for new disk.

You would see the new LUN, you have to create a Device Alias using the LUN's WWN number.

Make the new device alias and boot LUN.

A detailed user guide is provided on the Emulex Site. Please check.

Hope this helps....

Anonymous
Not applicable

Re: Boot from San

Hi Abdul,

Thanks for the provided information.

It is a Clariion CX600 and not sure about the Host.

I checked and found the attached document for EMULEX.

I have a couple of questions :

~ What is necessary within Navisphere for the allowing the Emulex HBA to properly "see" the boot lun? It appears that the Emulex BIOS will not load unless it sees either a viable LUN or specifically a boot LUN. Can you confirm either or both?

~ If we have a system with one HBA installed and is zoned to see SPA and SPB (SPA0 and SPB1) will the system be able to boot from its LUN? Does the boot LUN need to be owned by the SP that it can see at the time of boot up?

Kindly suggest.

0 Kudos
Anonymous
Not applicable

Re: Boot from San

Hi Abdul,

Thanks a lot for answering the question.

The information provided was a great help.

Regards

Vandy

0 Kudos