boydbria
2 Iron

Help needed: SERVER_IP: 6: The IPv6 default routers table is empty

Hey all,

VNX7600 -

Anyone remember how to disable IPv6 or get rid of this error message on a data mover:

“The IPv6 default routers table is empty.”

I’ve got a 4 data mover system and it’s spamming the logs (although not causing any issues…).

I’ve already created several routes (and adding default routes) for regular IPv4 addresses but since I'm not using IPv6 I would like to figure out how to get rid of this.

Coming up short on trying to find an answer with searching.

Thanks!

0 Kudos
5 Replies
Jyothi_P_Bharat
3 Argentium

Re: Help needed: SERVER_IP: 6: The IPv6 default routers table is empty

Hi,

I think you might have deleted the loop back interface for IPv6.

So could you please run these commands an dprovide the output:

server_ifconfig server_x -a

server_route server_x -list

Thanks

Jyothi

0 Kudos
boydbria
2 Iron

Re: Help needed: SERVER_IP: 6: The IPv6 default routers table is empty

I have never configured IPv6 nor have a need for it.  But here you go:

[nasadmin@CS07600 ~]$ server_ifconfig server_2 -a

server_2 :

el30 protocol=IP device=mge0

         inet=128.221.252.2 netmask=255.255.255.0 broadcast=128.221.252.255

        UP, Ethernet, mtu=1500, vlan=0, macaddr=0:60:16:52:92:c2 netname=localhost

el31 protocol=IP device=mge1

         inet=128.221.253.2 netmask=255.255.255.0 broadcast=128.221.253.255

        UP, Ethernet, mtu=1500, vlan=0, macaddr=0:60:16:52:92:c3 netname=localhost

loop6 protocol=IP6 device=loop

         inet=::1 prefix=128

        UP, Loopback, mtu=32768, vlan=0, macaddr=0:0:0:0:0:0 netname=localhost

loop protocol=IP device=loop

         inet=127.0.0.1 netmask=255.0.0.0 broadcast=127.255.255.255

        UP, Loopback, mtu=32768, vlan=0, macaddr=0:0:0:0:0:0 netname=localhost

server_2_int protocol=IP device=lacp2-fxg

         inet=10.20.133.232 netmask=255.255.255.0 broadcast=10.20.133.255

        UP, Ethernet, mtu=1500, vlan=0, macaddr=0:60:16:5c:e0:2

[nasadmin@CS07600 ~]$ server_route server_2 -list

server_2 :

default 10.20.133.1 0.0.0.0 server_2_int

net 128.221.253.0 128.221.253.2 255.255.255.0 el31

net 128.221.252.0 128.221.252.2 255.255.255.0 el30

net 10.20.133.0 10.20.133.232 255.255.255.0 server_2_int

host 127.0.0.1 127.0.0.1 255.255.255.255 loop

0 Kudos
boydbria
2 Iron

Re: Help needed: SERVER_IP: 6: The IPv6 default routers table is empty

Here is some more information.  DM's are configured just like another VG8 we have and there are no errors showing there.  I'm wondering if this is something wierd with file for VNX2..  Again we are NOT using IPv6 so having a log entry every 5 minutes is a bit chatty.

File version is: 8.1.1-33 (which I know there is an upgrade available)


Log errors every 5 minutes on every primary DM:

2014-04-24 10:48:49: SERVER_IP: 6: The IPv6 default routers table is empty.

2014-04-24 10:53:51: SERVER_IP: 6: The IPv6 default routers table is empty.

2014-04-24 10:58:49: SERVER_IP: 6: The IPv6 default routers table is empty.

2014-04-24 11:03:50: SERVER_IP: 6: The IPv6 default routers table is empty.

2014-04-24 11:08:49: SERVER_IP: 6: The IPv6 default routers table is empty.

2014-04-24 11:13:51: SERVER_IP: 6: The IPv6 default routers table is empty.

2014-04-24 11:18:49: SERVER_IP: 6: The IPv6 default routers table is empty.

Here is the route list for IPv6 stuff which looks correct for loopback.

server_ip server_2 -route -list

server_2 :

Destination                                 Gateway                                 Interface                               Expires (secs)

::1/128                                     ::1                                     loop6                                   0

0 Kudos
boydbria
2 Iron

Re: Help needed: SERVER_IP: 6: The IPv6 default routers table is empty

Still having errors.  Anyone see this out in the field?  I may just go w/ a code upgrade, although there is nothing specific to IPv6 in the new release notes except for control station stuff.

0 Kudos
Highlighted
rajans
1 Copper

Re: Help needed: SERVER_IP: 6: The IPv6 default routers table is empty

could you please check if there is a file called

/nas/server/slot_x/route6  and .route6.sig

what is the content of it  ? compare with the other slots.

also check if there is an entry /nas/server/slot_x/param file with a ipv6 entry  ?

checked a lab box and these messages appear to be normal

[nasadmin@vnxnr4-CS0 ~]$ server_log server_2|grep -i server_ip 2014-11-11 21:25:38: SERVER_IP: 6: The Neighbor Cache is empty. 2014-11-13 13:26:27: SERVER_IP: 6: The Neighbor Cache is empty. 2014-11-13 14:30:20: SERVER_IP: 6: The Neighbor Cache is empty. [nasadmin@vnxnr4-CS0 ~]$ server_log server_3|grep -i server_ip 2014-10-28 11:56:08: SERVER_IP: 6: The Neighbor Cache is empty. 2014-10-28 11:56:20: SERVER_IP: 6: The IPv6 default routers table is empty. 2014-10-28 13:06:01: SERVER_IP: 6: The Neighbor Cache is empty. 2014-10-28 13:06:12: SERVER_IP: 6: The IPv6 default routers table is empty. 2014-10-30 17:17:00: SERVER_IP: 6: The Neighbor Cache is empty. 2014-11-05 01:42:32: SERVER_IP: 6: The Neighbor Cache is empty. 2014-11-11 21:41:27: SERVER_IP: 6: The Neighbor Cache is empty. 2014-11-13 13:42:25: SERVER_IP: 6: The Neighbor Cache is empty. 2014-11-13 14:46:20: SERVER_IP: 6: The Neighbor Cache is empty. [nasadmin@vnxnr4-CS0 ~]$ server_log server_4|grep -i server_ip 2014-11-13 14:58:30: SERVER_IP: 6: The Neighbor Cache is empty. 2014-11-13 14:59:24: SERVER_IP: 6: The IPv6 default routers table is empty. [nasadmin@vnxnr4-CS0 ~]$ server_log server_5|grep -i server_ip 2014-11-05 01:47:11: SERVER_IP: 6: The Neighbor Cache is empty. 2014-11-13 14:51:55: SERVER_IP: 6: The Neighbor Cache is empty.

0 Kudos