MPIO for iSCSI for Hyper-V cluster on VNX5500

Hi All,

One of our customers is configuring Hyper-V cluster on VNX5500 block over iSCSI.

He observes the HLU to o/s ID mapping is not the same across all his cluster members & then the cluster validation fails in turn. The same LUN is identified with different disk IDs on different machines.

There is only MPIO enabled and iSCSI is the transport method.

Has anyone experienced the MPIO issue with iSCSI on VNX?

If, so can you advise me what remediation made to resolve the issue?

Kind Regards,

Upul.

Tags (2)
0 Kudos
1 Reply
parrig1
3 Argentium

Re: MPIO for iSCSI for Hyper-V cluster on VNX5500

Hi there

Can you copy/paste the cluster error here?

If you an error similar to the one below, you can try:

Error in the cluster log

00000a8c.00001530::2010/03/01-09:40:39.622 WARN  [RCM] ResourceControl(GET_CLASS_INFO) to Cluster Disk 4 returned 5038.
00000a8c.000015a0::2010/03/01-09:40:39.623 WARN  [RCM] ResourceControl(GET_RO_PRIVATE_PROPERTIES) to Cluster Disk 4 returned 5910


-Changed MPIO failover policy from Basic Failover to Round Robin or an Active/Active scenario (such as PowerPath default). 
  There is a performance issue with iSCSI in Microsoft Windows 2008 and later whereby the default TCP acknowledge time of the iSCSI Initiator is 200ms.
A TCP packet from the node's iSCSI initator to storage may be delayed up to 200ms if the packet's payload does not fill an Ethernet sgement (based on the configured MSS)

When using Microsoft's MPIO Round-Robin algorithm for iSCSI dealing with a larger number of Pass-through devices, the performance issue is exacerbated as there are now more
iSCSI initiator paths to storage, reducing the given payload of the iSCSI CDB (SCSI OpCode).

This problem does not appear as badly when using a single active path to storage. This problem is specific to iSCSI and does not exist in a Fibre Channel environment.

This can affect the time taken to perform failure recovery, such as determining SCSI reservations when performing owner take-over (arbitration).


Note: This is a Microsoft iSCSI Initiator problem and is not caused by any EMC software or EMC hardware.
            You may advise the customer to open a Support Case with Microsoft Product Support Services.

Note: This may negatively impact maximum network throughput (slightly - 1-2 % in testing)

1.  For each iSCSI Network Interface, follow Microsoft KB article KB 2020559  http://support.microsoft.com/?kbid=2020559

2.  Also, if the host is Windows 2008 R2 onwards, set the following parameter for improved send performance;

   In the registry editor also create the following DWORD key and assign it a value of 1.
                  HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E97B-E325-11CE-BFC1-08002BE10318}\<Instance Number>\Parameters\iSCSIDisableNagle

                   Where <Instance Number> is the instance of your iSCSI Initiator.

-This additional step shall be appended in the MSKB artcile 2020559 shortly.


-Reboot after making the registry changes.

Cheers!

0 Kudos