Highlighted
dg0ldsmith
1 Copper

Setting Control Station and Data Movers to use UTC zone for time

Pages 62-63 of the VNX System Operations document (http://corpusweb130.emc.com/upd_prod_VNX/UPDFinalPDF/jp/System_Operations.pdf) covers setting the timezones.  However it doesn't seem to work trying to assign "UTC" or "Etc/UTC" as the zone to use.

I was reviewing the hidden .ckpt directory for one of our NFS mounts to look at the checkpoints and noticed the VNX is using the zone name in the name of the checkpoint directories:

# ls -l .ckpt

total 192

drwxr-xr-x 8 root root 1024 Aug  2 02:37 2013_08_03_00.30.01_America_New_York

drwxr-xr-x 8 root root 1024 Aug  2 02:37 2013_08_04_00.00.03_America_New_York

drwxr-xr-x 8 root root 1024 Aug  2 02:37 2013_08_04_00.30.00_America_New_York

drwxr-xr-x 8 root root 1024 Aug  2 02:37 2013_08_05_00.30.01_America_New_York

drwxr-xr-x 8 root root 1024 Aug  2 02:37 2013_08_06_00.30.08_America_New_York

drwxr-xr-x 8 root root 1024 Aug  2 02:37 2013_08_07_00.30.14_America_New_York

Here is the results of trying to set the first data mover to use UTC by specifying both POSIX names and Linux names for the zone (referring also to pages 28-29 of https://mydocs.emc.com/VNXDocs/TimeServices.pdf😞

[nasadmin@vnx ~]$ server_date server_2

server_2 : Fri Aug  9 14:45:27 EDT 2013

[nasadmin@vnx~]$ server_date server_2 timezone -name Etc/UTC

server_2 :

Error 10279: server_2 : Invalid time zone: Etc/UTC.

[nasadmin@vnx ~]$ server_date server_2 timezone -name UTC

server_2 :

Error 10279: server_2 : Invalid time zone: UTC.

[nasadmin@vnx ~]$ server_date server_2 timezone UTC

server_2 :

Error 13157400579: server_2 : Invalid argument(s).

[nasadmin@vnx ~]$ server_date server_2

server_2 : Fri Aug  9 14:45:56 EDT 2013

Is it not possible to set the Data Mover to use UTC?  Do I need to use GMT instead?  We have all our servers and network equipment set to use UTC and would like to have the VNX use UTC as well to make time alignments easier to figure out when looking at logs.

Tags (4)
0 Kudos
1 Reply
christopher_ime
4 Beryllium

Re: Setting Control Station and Data Movers to use UTC zone for time

To view the possible choices I would recommend referring instead within Unisphere and the corresponding drop down lists:

Data Movers:

==========

1) System > Hardware > Data Movers

2) Right-click on the data mover > Properties

3) Then review the "TimeZone:" drop down list

4) Those are the *only* values that server_date will accept when using the "-name" parameter

Control Station:

============

1) Log into Unisphere as *local* root user

2) Under System Management > Control Station Properties

3) Review the "Current Timezone:" drop down list

0 Kudos