Highlighted
mjzraz
2 Iron

User quota frustration

I was hoping this was a little better in VNX... welll

I get "not responding" on the quotas window

In unisphere, I can't sort columns or filter.

There does not seem to be any background tasks running.

We migrated @ 700 GB each into 3 file systems on the new VNX @ 7000 users, with 13,000 more to come from Windows servers.

I already had user quotas checkbox checked on file system

Before going into production I needed user quotas enabled for these 3 file systems, So I did like I have in the past, On our Celerra NS80, I could manage user quotas thought the qouta tab on a drive mapped to the file system root.

After I set a default hard and soft quota, I can not manage quotas through unishphere GUI or Windows quota tab.  I used to be able to sort by space used and adjust multiple quotas at once for users that were beyond the default quotas.

It woudl seem that there is nothing easier than sorting by size selecting the range and adjusting the quota, except for it not being useable. Any ideas or is this just an area where VNX/Celerra is lacking useability?

Tags (3)
0 Kudos
10 Replies
mjzraz
2 Iron

Re: User quota frustration

Here is a sample of what I get from running:

[nasadmin@mtwvnx1 ~]$ nas_quotas -report -user -fs users1 >users1qoutas.txt

Report for user quotas on filesystem users1 mounted on /root_vdm_2/users1

+------------+-----------------------------------------------+-----------------------------------------------+

|User        |                 Bytes Used  (1K)              |                    Files                      |

+------------+------------+------------+------------+--------+------------+------------+------------+--------+

|            |    Used    |    Soft    |    Hard    |Timeleft|    Used    |    Soft    |    Hard    |Timeleft|

+------------+------------+------------+------------+--------+------------+------------+------------+--------+

|anonymous   |    20347848|           0|           0|        |       43147|           0|           0|        |

|#32768      |    26047738|           0|           0|        |       78009|           0|           0|        |

|#32771      |     1862729|           0|           0|        |        3357|           0|           0|        |

|#32774      |           0|           0|           0|        |           1|           0|           0|        |

|#32784      |           0|           0|           0|        |           1|           0|           0|        |

|#32789      |     1598622|           0|           0|        |        1494|           0|           0|        |

|#32808      |       11330|           0|           0|        |          83|           0|           0|        |

|#32814      |         392|           0|           0|        |           7|           0|           0|        |

|#32835      |         138|           0|           0|        |          17|           0|           0|        |

|#32839      |     4880192|           0|           0|        |        1957|           0|           0|        |

|#32845      |      136154|           0|           0|        |         128|           0|           0|        |

|#32846      |      839017|           0|           0|        |        1236|           0|           0|        |

|#32847      |      230196|           0|           0|        |          82|           0|           0|        |

|#32848      |       19912|           0|           0|        |          11|           0|           0|        |

|#32849      |      356082|           0|           0|        |         339|           0|           0|        |

|#32850      |        2869|           0|           0|        |          30|           0|           0|        |

|#32851      |       12667|           0|           0|        |          32|           0|           0|        |

|#32852      |           0|           0|           0|        |           1|           0|           0|        |

|#32853      |           4|           0|           0|        |          10|           0|           0|        |

|#32854      |       35608|           0|           0|        |         327|           0|           0|        |

It seems like there are no hard or soft quotas!

yet... I get this:

[nasadmin@mtwvnx1 ~]$ nas_quotas -report -config -fs users1

+------------------------------------------------------------------------------+

| Quota parameters for filesystem users1 mounted on /root_vdm_2/users1:

+------------------------------------------------------------------------------+

| Quota Policy: filesize

| User Quota: ON

| Group Quota: OFF

| Block grace period: (333.3 months)

| Inode grace period: (333.3 months)

| Default USER quota limits:

|     Block Soft: (   5242880), Block Hard: (   6291456)

|     Inode Soft: (         0), Inode Hard: (         0)

| Default GROUP quota limits:

|     Block Soft: (         0), Block Hard: (         0)

|     Inode Soft: (         0), Inode Hard: (         0)

| Deny Disk Space to users exceeding quotas:      YES

| Log an event when ...

|    Block hard limit reached/exceeded:           YES

|    Block soft limit (warning level) crossed:    YES

|    Quota check starts:                           NO

|    Quota Check ends:                             NO

+------------------------------------------------------------------------------+

Is it because the files and folders were already there when I set the default hard and soft quotas?

0 Kudos
Rainer_EMC
5 Rhenium

Re: User quota frustration

Make sure you are on the latest VNX OE release

If yes – please open a service request

0 Kudos
Rainer_EMC
5 Rhenium

Re: User quota frustration

You could try a quota recalc

0 Kudos
mjzraz
2 Iron

Re: User quota frustration

We are on the latest release. I'll open a request. Thanks

I ran  [nasadmin@mtwvnx1 ~]$ nas_quotas -check -status -fs users1

same output for nas_quotas -report -user -fs users1 hard /soft 0/0

0 Kudos
Rainer_EMC
5 Rhenium

Re: User quota frustration

You need to start the recalc with the –start option before checking the status

0 Kudos
mjzraz
2 Iron

Re: User quota frustration

Rainer_EMC wrote:

You need to start the recalc with the –start option before checking the status

I did - It's the 3 hours of sleep that's killing me - this migrationwas supposed to have been last night, but I had 2 issues, The "new" default permissions registry options for homedir that I had to test because I didn't know the options existed, and then this quota problem.

I ran nas_quotas -check -start -mode online -fs users1

then ran  the status to see if it was running

and thanks for helping

0 Kudos
mjzraz
2 Iron

Re: User quota frustration

I have a service request open, but not much progress in a week...

They went straight to the code upgrade solution since there is a fix (below) in 7.0.50.2 however I already told them we were on the following:

Block Software Version: 05.31.000.5.709

File Software Version: 7.0.51-3

I did find something interesting in testing. I took a small file system @ 400GB and I was the only account that had ever written to that file system. I copied @ 100 large files to the file system. I enabled user quotas and set a default hard and soft limit. When I mapped a drive and openened the properties window and clicked on quota entries I got a window that hung like before and an hourglass. I left this PC alone for 16 hours and when I returned, the hourglass was gone and I saw the quota entries - over 8 million quota entries for my used ID!! I think that is the problem

screen shot:

https://jshare.johnshopkins.edu/xythoswfs/webui/_xy-11948169_1-t_iUNWJ51j

I can only imagine that with 3000 users and their files how many entries there would be.


Solution ID: emc274263 Date Created: 07/26/2011 Last Modified Date: 03/14/2012

Here is the solution:  Unisphere slows down or hangs when trying to manage a large number of quotas.

It is a known issue under NAS 6.0 and VNX for FILE OE 7.0 code that Unisphere will slow down or freeze up when generating the list of quotas in environments with a large number (1000 and more) of quota objects.

Fix:

•          NAS 6.0 code - A fix is available in 6.0.51.6 and later code.

•          VNX for FILE OE 7.0 code - A fix is available in 7.0.50.2 and later code.

Workaround:

The only workaround is to use the command line interface (CLI) nas_quota command to manage quotas until the code has been upgraded to a level that contains the fix.

Causes of this problem:

For a large number of quota objects in the quota tables, users will experience significant delays when Unisphere generates the list of quotas. This behavior is particularly pronounced for user and group quota pages, where the screen refreshes itself several times. Each refresh causes significant delay in screen refresh that appears like a hang to the user. Unisphere is not usable for several minutes to hours if a very large number of quotas have been configured.

0 Kudos
bergec
2 Iron

Re: User quota frustration

Are you running the latest 7.0.53 code?

There seem to be an error in previous release where when SMB2 clients (Windows 7 / W2K8 / Vista) try to view Quotas for a filesystem he get warning messages with the same login name and size of quotas

As of 7.0 his should be fixed in 7.0.53.103 7.0.53.102 7.0.53.101 7.0.53.100

You could open a Service Request in order to know when these release (or if already) will be available

Claude

0 Kudos
mjzraz
2 Iron

Re: User quota frustration

Claud,

Thanks! We are at 7.0.51-3. I never thought to check the quotas on a Windows XP or server 2003 box.

They work like a charm!

0 Kudos