Renso1
Not applicable

vnx5400 SMI-S Provider Not Supported

Hi all.

SMI-S Provider (Solution Enabler) cannot register vnx5400 storage system:

getagent from both SP

Agent Rev:           7.33.8 (1.19)

Name:                K10

Desc:

Node:                A-CKM00140700155

Physical Node:       K10

Signature:           3686485

Peer Signature:      3678211

Revision:            05.33.008.5.119

SCSI Id:             0

Model:               VNX5400

Model Type:          Rackmount

Prom Rev:            33.40.00

SP Memory:           16384

Serial No:           CKM00140700155

SP Identifier:       A

Cabinet:             DPE9

dv from TestSmiProvider (run from same host as the navicli)

(localhost:5988) ? dv

++++ Display version information ++++

CIM ObjectManager Name: EMC:

CIMOM Version: EMC CIM Server Version 2.8.4.0.0.112

SMI-S qualified version: 1.5.0

SMI-S Provider version: V8.1.0.0

SMI-S Provider Location: Proxy

SMI-S Provider Server:

Linux 3.8.13-68.3.3.el6uek.x86_64 #2 SMP Tue Jun 23 23:43:15 PDT 2015 x86_64 VM Guest OS (64bit Libraries)

Solutions Enabler version: V8.1-2054 0.0

addsys result

(localhost:5988) ? addsys

Add System {y|n} : y

ArrayType (1=Clar, 2=Symm) [1]:

One or more IP address or Hostname or Array ID

Elements for Addresses

IP address or hostname or array id 0 (blank to quit): 172.17.111.101

IP address or hostname or array id 1 (blank to quit): 172.17.111.102

IP address or hostname or array id 2 (blank to quit):

Address types corresponding to addresses specified above.

(1=URL, 2=IP/Nodename, 3=Array ID)

Address Type (0) [default=2]:

Address Type (1) [default=2]:

User [null]: manager

Password [null]: ******

++++ EMCAddSystem ++++

OUTPUT : 1

Legend:0=Success, 1=Not Supported, 2=Unknown, 3=Timeout, 4=Failed

       5=Invalid Parameter

       4096=Job Queued, 4097=Size Not Supported

Note: Not all above values apply to all methods - see MOF for the method.


OUTPUT : 1

in Leged 1 for "Not Supported"

similar result on Windows SMI-S Provider (same version)

As far as I understand , vnx5400 must support SMI-S and registration on SMI-S Provider

Please help with this problem.

Labels (1)
0 Kudos
7 Replies
Rainer_EMC
6 Indium

Re: vnx5400 SMI-S Provider Not Supported

Please see the SMI-S provider release notes

You need to install SMI-S provider version 4.6.2 for VNX support

0 Kudos
kelleg
5 Rhenium

Re: vnx5400 SMI-S Provider Not Supported

Was your question answered correctly? If so, please remember to mark your question Answered when you get the correct answer and award points to the person providing the answer. This helps others searching for a similar issue.

glen

0 Kudos
JovAe_V
2 Bronze

Re: vnx5400 SMI-S Provider Not Supported

Same issue here

Solutions Enabler SMI-S Provider 8.1.0

VNX 5700

Addsys results in 1 - Not supported

Interoperability issues between 8.1.0.0 VNX?

0 Kudos
Rainer_EMC
6 Indium

Re: vnx5400 SMI-S Provider Not Supported

as I had written above SMI-S provider 8.1 doesnt support VNX - you need to install the SMI-S provider version 4.6.2 for VNX support

This is also documented in the release notes.

0 Kudos
Rainer_EMC
6 Indium

Re: vnx5400 SMI-S Provider Not Supported

@Renzo and @JovAeV

can you please confirm that it works now once you have installed the correct Version of the SMI-S Provider ?

0 Kudos
JovAe_V
2 Bronze

Re: vnx5400 SMI-S Provider Not Supported

Yes, once SMI-S 4.6.2 was installed VNX arrays were discovered again without problems. Too bad 8.1 is not supported (yet). Any ideas when it will be?

0 Kudos
Rainer_EMC
6 Indium

Re: vnx5400 SMI-S Provider Not Supported

you will need to stay on the 4.6 family

0 Kudos