Highlighted
A p u
1 Copper

Hyper-V networking slow

Jump to solution

Dell PowerEdge T420, Windows Server 2008 R2 with Hyper-V installed and a single 2008 R2 virtual machine setup within the Hyper-V environment. The two NICs on the T420 are connected to the same Gigabit switch, one for the physical machine's use and the other for the virtual network.

The only thing being done in the VM is Remote Desktop Services and then end-users running a medical records program which is accessing a database on completely separate server. The physical server just has Hyper-V, a domain controller and DNS.

With no activity, ping'ing the guest from the physical machine or vice versa, or a separate database server from the guest machine, we get under 1 ms response times. However, if there is any activity in the guest OS, ping times vary drastically -- between 1 ms and 200 ms.

I have the various Offloads disabled in the virtual network adapters properties but that does not seem to make any difference. Looking at the Resource Monitor on the virtual machines, there is generally under 5% of the CPU and 10% of the memory being used, and network traffic when the application is running is under 100 Kbps (usually under 50 Kbps).

On the physical server, the CPU & network traffic are basically the same as the virtual machine, with 80% of the memory in use (since it is all allocated to Hyper-V).

Any thoughts on how to solve the slow networking?

Thanks in advance!

0 Kudos
1 Solution

Accepted Solutions
A p u
1 Copper

Re: Hyper-V networking slow

Jump to solution

The solution to the problem turns out to be...

The Broadcom NICs in this Dell server have a setting "Virtual Machine Queues" that defaults to enabled. Once disabled, the guest OS has the same network speed as the physical machine does.

4 Replies
A p u
1 Copper

Re: Hyper-V networking slow

Jump to solution

The solution to the problem turns out to be...

The Broadcom NICs in this Dell server have a setting "Virtual Machine Queues" that defaults to enabled. Once disabled, the guest OS has the same network speed as the physical machine does.

Re: Hyper-V networking slow

Jump to solution

That worked for me. Thanks!

0 Kudos
Francisco M.
1 Copper

RE: Hyper-V networking slow

Jump to solution
If you're running "Hyper-V Server 2012 R2" then you will not have the GUI and you might ask how to disable "Virtual Machine Queues". First download the newest Broadcom Driver, on my Power Edge T420 I downloaded... "Broadcom Windows 64bit driver update for NetXtreme I and NetXtreme II Ethernet adapters for the 18.2.2 update." and used the "File Format: Update Package for Microsoft® Windows" copy the file over to the Hyper-V host and via a command prompt on the host run the exe file. I left all default options. Even being a core version of windows server this install will run like a normal windows server. (By the way, it did NOT disconnect me.) Once installed the via command prompt go and run "c$\Program Files\Broadcom\BACS\bacs.exe". Broadcom Advanced Control Suite will open. Here drill down till you find and disable ""Virtual Machine Queues" (It's a drop-down, just click on it.) I suggest you do it for every NIC you have on the host.
Tags (1)
PPRINetadmin
1 Copper

RE: Hyper-V networking slow

Jump to solution

Ok, I know this is a very old thread.

But... I am having this same problem on our PowerEdge R820 servers running Hyper-V in a 4 server cluster.

These servers do not have a Broadcom card - they use an Intel 4P I350-t NICs.   But the same setting (Virtual Machine Queues) is still there and is still Enabled by default.

 

Before I go and start changing settings, I need to ask:   Does this NIC have the same issues as the Broadcom.

0 Kudos