Highlighted
tamilgirl
1 Nickel

DEP message on starting comp: COM Surrogate

I am a newbie to forums. I have searched on the net and was not meeting with any success. So am posing my query here:

When I start my inspiron 530 running win xp home, i get a DEP window with a message: To help protect your computer, Windows has closed this program. Name: COM Surrogate

Does this mean that I may have a virus or spyware on my comp.?!

Please help!

0 Kudos
5 Replies
8 Krypton

Re: DEP message on starting comp: COM Surrogate

Hi, tamilgirl, and welcome to the forum.

This message does not imply infection.

The link below suggests possible fixes for that error using Vista. I have no idea if it works for XP Home, but any changes suggested can be reversed if they don't solve your problem, so they are safe to try.

Scroll down a bit to the section that begins:
"Essentially, turning off Data Execution Prevention on dllhost (the COM surrogate) can fix this problem for some people. This solution is detailed below." and follow the detailed instructions.

http://www.howtogeek.com/howto/windows-vista/fix-for-com-surrogate-has-stopped-working-error-in-vist...

Let us know how it goes.

_________________________________________


Dell Forum Member since 2,000


 Use OpenDNS   MalwareBytes' Anti-Malware Free


Windows 7/sp1 (64- Bit): Malwarebytes 3.x Premium, Windows Firewall, WinPatrol PLUS, Emsisoft Emergency Kit Free and HitmanPro Free (on-demand scanners), OpenDNS, MVPS Hosts file, SpywareBlaster, Pale Moon web browser, Sandboxie, CCleaner Free.


Windows 10 Pro (64- Bit): Same protection plus Windows Defender AV.


"In the future, everyone will be anonymous for 15 minutes" - Banksy

0 Kudos
8 Krypton

Re: DEP message on starting comp: COM Surrogate

I just had this exact error on my husband's Dell Inspiron 6000 with Windows XP sp2.  All that would come up was the desktop wallpaper and no icons or task bar or anything.  He found out to do ctlr+Alt+del to bring up the task manager and then click New Task and put in explorer.exe to bring up the desktop.  Well I disabled the DEP Which you are not ever suppose to do and then it could boot normally.  I searched the net and found out one cause could be a program called DivX.  I went into add/remove and deleted everything to do with DivX. 

But I think the thing that really fixed it was to do a Start-Run and type  sfc  /scannow.  Be sure to put a space after the sfc. It ran for a while and just ended with no report and didn't ask me to insert the OS disk.  When it looked like it was done I rebooted and it worked ok.

 

Good Luck!

0 Kudos
tamilgirl
1 Nickel

Re: DEP message on starting comp: COM Surrogate

thanks, volvogirl!

i did as you said and the DEP message has disappeared!

thanks joe53 for your suggestion. however, i was scarred to try as i am using win xp and i was getting the message on starting the comp and not for viewing video as was mentioned there. i sincerely appreciate your help, though.

0 Kudos
8 Krypton

Re: DEP message on starting comp: COM Surrogate

Which thing did you try?  Because you don't want to disable the DEP!  I disabled mine but put it back on after I got it fixed.  While I had mine off I kept the internet completely shut off too.

0 Kudos
tamilgirl
1 Nickel

Re: DEP message on starting comp: COM Surrogate

I ran the sfc /scannow thingy and it ran for a while. after that, boom!-----no more warning!

cheers

0 Kudos