1 Nickel

Can't rerun Compatibility check, after "CPU not supported" apparent fixes on my Studio 540

I have a Dell Studio 540 running Windows 7. The CPU is an Intel Core 2 Quad Q8300.
The computer is around 5 years old. I am trying to upgrade this to Win10 but I am having problems with the Compatibility checker.
(I should add that the Windows 8.1 compatibility check runs fine and shows NO issues)

Initially, when Windows 10 compatibility check appeared on my computer I received an error saying the CPU was not supported”
Looking around at the time, I discovered there was a bug and some computers were incorrectly assessed.
A few months later, supposedly once the Windows updates ran and corrected the compatibility bug, I did get a message saying my computer was in fact fine for an upgrade.

I did not do the upgrade at the time, but when I tried the other day, I got the initial compatibility error message again stating my CPU is not supported.
Running CPU-Z, under “Instructions” it is compatible with: SSE2, EM64T and VT-x(see attachment)
My BIOS supports XD and CPU-Z confirms correct compatibility as required for Windows 10.

At the time, looking at Data Execution Protection under: “My Computer > Properties>Advanced System Settings> Advanced>Performance Settings> Data Execution Protection” all options were grayed out.
I enabled it via a cmd prompt:
bcdedit.exe /set {current} nx AlwaysOn 
bcdedit.exe /set {current} nx optin

The result is that I could then enable DEP this way and I have selected “Turn on DEP for all programs and services except those I select” (see attachment)

Hopefully all this solves the problem,  however now the Compatibility check wont rerun (last reran a few days ago before I performed the above steps).
I have tried the force rerun script as administrator: “schtasks.exe /Run /TN "\Microsoft\Windows\Application Experience\Microsoft Compatibility Appraiser"Yet the checker still wont rerun. I have also deleted the files in"C:\Windows\SoftwareDistribution\Download". and then run (as administrator) "C:\Windows\system32>wuauclt /updatenow"as some forums suggest.

Still no luck in getting the compatibility check working – this is driving me crazy.

Any ideas why I may be getting this error, and how would I overcome it?


0 Kudos
1 Reply

RE: Can't rerun Compatibility check, after "CPU not supported" apparent fixes on my Studio 540


Product not tested for Windows 10 upgrade

Dell is not testing or developing Windows 10 drivers for this product. If you choose to upgrade, some features, applications, and connected devices may not work as expected.

For me to better assist in troubleshooting, please click my DELL-Jesse L and send me a Private Message with the Dell Service Tag number and your Dell Order number.


Social Media Support
To help us troubleshoot, send us via a private message: Dell PC or Monitor Service Tag number
Out of Warranty Support
Where do I find my Dell PC Service Tag or Express service code?
Where do I post SA (SupportAssist) issue/questions?
0 Kudos