Windows 10

Start a Discussion
2 Bronze
2 Bronze

Dell E7440, Dell Security Tools issue with Windows 10


I have upgraded my Latitude E7440 to Windows 10 but Dell security tools stopped working (along with fingerprint sign in, etc).

I also installed the new version for Windows 10 that Dell uploaded in Aug 4th but there is no solution to the problem. Dell security tools is not working. Does anyone else face the same problem?

Big frustration when you install the new driver which is supposed to be for Windows 10 and simply doesn't work, poor performance and support from Dell unfortunately...

Replies (6)
2 Bronze
2 Bronze

I am having the same problem on an M6800 with the FIPS fingerprint reader (not the swipe reader, the touch sensor).  When I upgraded from Windows 8 Pro to Windows 8.1 Pro the Security Tools stopped working properly,  I had to remove all the Dell Security apps and associated installations in the control panel "uninstall a program" window (Dell Data Protection Client Security Framework and others),  then reinstall the apps. 

The fingerprints themselves are not deleting from the DDP Console this time;  last time I was able to delete the fingerprints and then re-enroll and then it started working. 

I tried clearing the fingerprint reader itself,  and I even tried disabling and re-enabling the reader and the TPM (Trusted Platform Module) and nothing is working.

I will provide you with any solutions I come across,  I believe whatever works on the M6800 should work on your computer since the software is the same.

Try to remove all prior settings and then uninstall and reinstall all security software.   I recall seeing that this software is specifically supposed to support windows 10,  but something isn't working right.

Looking back, I probably should have removed the security software "before" upgrading to Windows 10,  that might have avoided these issues.  Perhaps a registry key needs to be manually deleted and/or configuration settings need to be cleared during the uninstallation of the security tools (that was an option selected when the uninstaller was running).

When I click on the "select login options" under my user account photo in the Windows 10 login screen (I think that's what the link says - something like that),  I see the options I can select for logging in.  It defaulted to using a regular password,  but the thing that indicated a problem is that there was 2 different options for fingerprints,  as if there was 2 fingerprint reader devices from which I could select to use for login in addition to the normal password login.

Do you see 2 tiles/buttons for fingerprints in the login/sign-in options screen in Windows?

2 Bronze
2 Bronze

Thank you for your useful reply.

In my case I was seeing only one button for fingerprints in the login options screen in Windows 10, but it wasn't working when Dell security tools was installed.

Based on the things you described I did the following and my issue was resolved:

Also in my case, the fingerprints were not deleting this time from the DDP Console when trying to do it manually. Moreover, when tried to uninstall and reinstall the security software (without deleting the user data) from the Windows Control Panel the problem was still there.

But when I chose the option to completely delete all user data (it gives you this option when uninstalling the security software) and then I reinstalled it my issue was resolved. Now it seems to work again normally.

The disadvantage is that you lose all your stored credentials/fingerprint data and you have to insert them again..but at least it worked for me. You could also try the same and hope it will work for you.

Now , next step to try to resolve some other issues that are still apparent with Windows 10...

2 Bronze
2 Bronze

I also finally succeeded in getting it to work by the early AM hours today - and like you I had to re-enroll every fingerprint.

The password manager allows you to backup your credentials in Security Tools,  but that does not backup the other security data such as fingerprints.

I guess every time they update the Security Tools to a new version or update the OS we will have to set up the security tools the same way.  In-place upgrades to software applications and OS's is sometimes problematic,  so Dell chose to completely remove the existing security package before we upgrade.  However,  I would expect at least a semi-automated removal of the old apps when upgrading to a newer version.  The issue could be with the fact that the software itself doesn't really store our fingerprints - at least not in my FIPS fingerprint reader pad,  it is stored in the security hardware device itself (much more secure);  that might have something to do with the difficulties we had. 

The option to retain user data during the install might be for cases where you are reinstalling the same version of the app - such as in repairing a fault in the program.

My computer is a different model,  but by chance do you have trouble with Outlook 2013,  mine doesn't work properly, the screen is scrambled beyond recognition unless I start Outlook in Safe Mode - every add-on had been disabled and it still doesn't work - even remove and reinstall doesn't help.  Windows 10 apparently wasn't quite ready,  but that is why they only gave it to insiders or OEM manufacturers so far.

2 Bronze
2 Bronze

Unfortunately I have no experience with Outlook 2013 in my computer, I stopped using an earlier version at some point with a previous laptop I had, because I considered it as a rather 'heavy software' for what it offered..

My current issues have to do with the Wifi driver and the Dell 5570 Mobile Broadband card driver.

Although the Wifi seems to work fine, the Wifi LED on my laptop remains ON even when I switch it off via the hardware switch.

The Mobile card driver on the other hand doesn't work at all, even though I uninstalled - installed the Windows 10 driver version. But I can see it becoming a topic of discussion in another thread..

2 Bronze
2 Bronze

In my computer, in the Device Manager, there is a piece of hardware and its associated Dell drivers labeled "airplane mode switch" and a second one labeled "airplane mode switch collection" - both of which don't seem to have function key combination triggers or a mechanical switch.  They are likely the drivers for the firmware on the wireless devices themselves,  used to turn those wireless radios on and off based on power savings rules and a software button I have in the system tray for enabling or disabling "airplane mode"

I think the problem you have is more of a firmware-type control between the hardware and OS than a device driver problem - basically the method used by the OS to turn those wireless devices on and off for power savings is not working properly...  The fact that your light stays on regardless of switch position makes me think that.  The switch probably doesnt work like a light switch that cuts the power to the device,  it likely works similarly to the action of pressing the FN key combination - triggerinng the OS to change the power state to the opposite it is at that time (on or off)..   The switch probably sends an instruction to the OS thru a driver or firmware telling the OS to turn off the wireless radios.  By flipping the switch the signal is sent but it doesn't work, so the wireless light stays on..

This is all my best guesses as to what is going wrong and the exact function of the hardware (based on a lot of past experience with various notebook troubleshooting),  hopefully it gives you enough info to try and troubleshoot it..

There is a setting in my bios that allows me to choose which wireless devices are controlled by this "wireless switch" software/firmware process;  Bluetooth, WiFi, WiGig, and WWAN card (mobile broadband card) can all be included or excluded from the power savings settings.  I suspect there is not a driver issue but in fact an issue with the method that the device is turned on and off for power savings and/or Airplane mode. 

I would check your BIOS or UEFI Setup (whichever your computer uses -  UEFI is just a newer replacement for a BIOS but looks similar) for wireless card settings... Many notebooks have more than one Mini-PCI slots,  my current and some prior dell notebooks only allowed the card in a specific slot - even when the antenna wires for the Mobile Broadband card could reach either slot,  the system required it in a specific slot for some reason - maybe for power control reasons.  Did you install the card, or Dell.  If it worked in the past and was installed by Dell,  then I would think you arent looking at a driver problem with the wireless device itself,  look at the things I mentioned above.

If it is in fact a driver issue,  you might have to start windows in safe mode,  then check the device manager for possible duplicate entries for that card,  sometimes "show hidden devices" shows a second driver installed that is not activated but could be interfering with the driver that is running..   Be very careful about deleting items from the device manager,  but if you have a second hidden mobile broadband card driver installed to a phantom device,  then I would try removing that,  but I still think its a power control issue since the light stays on when you turn the switch off...   the card is recognized by the system since part of it is always functioning,  but the radio power might be off...

Let me know if you have any additional info after checking these things.  Windows 10 may even have an update that resolves a windows system problem that could be causing this to happen - they already created a large update with countless bug fixes,  manually run windows update in the settings window and install the update if you didnt already, that alone could fix issues like that in some cases.

If there are not any problems with the items I mentioned above,  then

2 Bronze
2 Bronze

After a couple of days monitoring the behavior of the system and trying to figure out what is wrong, I haven’t reached a safe conclusion, but it is quite possible that there is some issue with the official driver (Dell Wireless 5570 WWAN Mobile Broadband and GNSS (GPS) Driver) or something interferes with that when installed.

First of all, the card was originally installed by Dell and worked in the past (or at least I hadn’t noticed any issue). Also, in the bios there is indeed the setting that allows me to choose which wireless devices are controlled by the “airplaine mode switch” and all of them are selected by default. In the Device Manager of my computer I also have the "airplane mode switch" and "airplane mode switch collection” entries along with the associated Dell drivers.

WHEN the official Windows 10 Dell driver for the WWAN card is INSTALLED:

- I notice this behaviour with the light staying on regardless of the switch position. This behavior is not consistent, meaning that sometimes it might work and the light will turn off (but most of the times it will not).

- Also, in the Device Manager I can sometimes see the entry for the WWAN card under the Network adapters but sometimes I cannot (in that case it is only shown under the ‘hidden devices’ view). Accordingly, the option for the ‘Cellular interface’ does not show up in the system tray (where I usually see the network interfaces) or in the Settings-> Network & Internet -> Flight Mode settings menu. Under Flight mode settings the ‘GPS’ option also appears for the card.

- The driver details for the card in the Device Manager keep showing Microsoft and not Dell as provider.

WHEN I UNINSTALL the Windows 10 Dell driver/software for the WWAN card:

- The light behaves correctly depending on the switch position (on/off).

- The WWAN device is shown normally in the Device Manager and the corresponding option in the system tray (the driver details are the same as before – Microsoft as provider)

- The 'GPS' option doesn’t appear in the Flight mode Settings menu.

I have no explanation other than the Dell driver might interfere with something else, but still I have not installed anything else other than what Dell officially provides for this model via their website.. In the device manager there were some duplicate entries for the card (shown as hidden devices) which I deleted.

Top Contributor
Latest Solutions