Highlighted
astroXP
1 Copper

I cannot reset or use the system recovery or system restore my Dell XPS 9350

I'm not sure what it's going on with my laptop but I cannot do anything when trying to upgrade or reset or reinstall or even use the system recovery partition at all.

BACKGROUND:

I have been using my Dell XPS 13 (9350) for a little over a year with no problems. I use the TB15 dock via USB-C to connect to my Dell P2715Q monitor. Recently I did a reset on my computer (late February) and that's when problems started popping up. I noticed that I would get this pop-up whenever I tried to connect to the dock

After selecting "Always Connect" to both options, it would trigger a BSOD. ALWAYS.

The error is SYSTEM_THREAD_EXCEPTION_NOT_HANDLED. According to what I researched, it is caused due to old or incompatible graphic card drivers. Even after I reinstalled the latest drivers for my dock, it didn't fix anything. So, after dealing with this annoyance longer than I could (over a month, I would just ignore the Approve Thunderbolt Devices window, I could mirror to my monitor but could not use any of the I/O ports on my dock), I decided to reset my computer once again.

This time I used the system recovery option so it would reset my computer to its factory image. After doing so, and once I logged in. I wanted to update to the latest Windows 10 build available.

PROBLEM:

The factory Windows 10 build that came pre-installed in my computer is Version 1511 (OS Build 10586.873). The latest Windows 10 build available as of today is 15063.

So I went to Settings > Update & Security > Windows Update > and checked for any updates. Updates downloaded, I restarted my computer but then I was presented with several errors. The update process would fail several times.

In fact, several error messages would show saying something was wrong but didn't provide more information.

After so many times of trying to fix this and wasted so much time, I decided to do once again a system recovery (I tried doing a reset and even a system restore but same results showed up) but now when I was at the screen where it prompted my administrator account password, it marks it as wrong.

I made sure I was typing it right. I knew my password is right. Anywho. I decide to create a second administrator account just to narrow things down. I created a Tony account with "hello" as a password. There's no way I could misspell that. Lo and behold, the system marks it wrong as well.

I've ran out of ideas as to what I can do.

Please help and advise!!!

0 Kudos
1 Reply
8 Krypton

RE: I cannot reset or use the system recovery or system restore my Dell XPS 9350

After the creators update, I used my TB 16 dock and it was recognized normally.  You don't mention why you initially reset your system, but once you go down that rabbit hole, hard to tell where you are.

You say the system came with Win 10 but don't say which version it is currently running.  Have you been having problems updating?   If you were able to upgrade to 1703 (15063), the best thing to do would be to download the install media and then use it to install over the current install.  That would replace the Win 10 components while leaving your stuff alone.

If you have been having problems with the system, you do have the capability of doing a clean install but you would lose any OEM capabilities and software.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos