sultanoflondon
1 Copper

Inspiron 3847, 0xc000021a error after updating the software

Hi all, I get a 0xc000021a error upon booting up. The Dell tries Automatic Repair but fails. After doing some research, I found that the following allows the computer to boot up: Advanced options > Troubleshoot > Advanced options > Startup Settings > Disable driver signature enforcement. Then the PC boots up as expected. After managing to boot the computer up, I tried the following. I uninstalled any unnecessary software, removed what I thought to be the updates that I had done, disabled everything in the start up sequence & none of this worked. I tried to disable driver signature enforcement permanently using Command, but it didn't let me, stating that it was in place for my computer's safety. I don't mind doing a reset of my computer as a last resort, but I would lose Microsoft Office as I don't think I have registered it & I don't have the product key with me. Are there any suggestions here on how to get this fixed? Am quite frustrated that a simple software update caused what seems to be fairly deep damage to the software of my computer. Thanks in advance!

0 Kudos
3 Replies
7- Thorium

Re: 0xc000021a error after updating the software

Always include exact PC model and version of Windows in your posts.

What software did you update?

If turning off signature enforcement helps, reboot and immediately press F2 to open BIOS setup. Look for the "Secure Boot" option and disable it. Do NOT change anything else in BIOS setup, but save the change to Secure Boot before exiting setup.

Does that solve the problem?

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
sultanoflondon
1 Copper

Re: 0xc000021a error after updating the software

It's an Inspiron 3847. Unfortunately, that didn't solve the problem.
0 Kudos
7- Thorium

Re: 0xc000021a error after updating the software

Get PC to boot up to desktop and right-click Start>Search. Type in CMD and when it appears on the search list, right-click it and "Run as Administrator". Now type the following into the CMD window (pay attention to the spaces):

 

bcdedit.exe /set nointegritychecks on
Press <Enter>
When the prompt reappears, close the CMD window and reboot.

NOTE: This will edit the boot configuration which you do entirely at your own risk. Back up your personal files on external media first, and be aware that you're disabling a level of security on your system.

 

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos