1 Copper

Installed Dell Update, USB mouse no longer works

I recently purchased a Genius USB plug-in mouse, which worked perfectly straight off the bat. However, after installing the most recent Dell update, it no longer works - not even showing up on the list of connected devices. I have tried updating the drivers on HID-compliant mouse and PS/2 compatible mouse on the devices list, to be told they are already up to date. 

Is there a fix for this? The box specifically mentions "There's no software to install" - I don't know if that includes drivers or not. My USB connected headset is still working fine, and that uses drivers, so I don't know what could be the issue. 

I have tried using different USB ports, with no effect. 

Tags (1)
0 Kudos
2 Replies
Community Manager
Community Manager

RE: Installed Dell Update, USB mouse no longer works

Hi Thrownfar,

Thanks for posting.

It would be easier for us to understand your issue if you could please post your model of computer.  Thanks.

Dell-Robert P
Social Media Support
To help us troubleshoot, please send us the Dell service tag number via a private message
Would you like to be a Dell Community Rockstar?

0 Kudos
4 Ruthenium

RE: Installed Dell Update, USB mouse no longer works

In device manager there may be a couple of things to try.

Set it to view hidden devices.  Then uninstall all versions of the mouse.  If any are grayed out, that means they are not currently used so uninstall those.

Also, check the USB Hubs to see if one or more have an advanced tab where you might find a reset hub button.


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos