toesbin
Not applicable

New Inspiron 15 3000 3567 - Freezing, non responsive programs

Less than a week ago I bought a Inspiron 15 3000.  So far it's been nothing but disappointment.  To start, the Cortana program would only completely kill any attempt at loading programs.  I've since disabled, however, Google Chrome, which I use for work, constantly stops responding.  I've tried to download apps from app store and get error messages.  I will go to close out of programs and the time from click to window close can be up to 30 seconds. 

Anyone else experience such lag?  I'm pretty disappointed considering it has no real programs up and running yet as it's a week old.  Trying to decide what to do.

0 Kudos
1 Reply
DELL-Jesse L
Community Manager
Community Manager

RE: New Inspiron 15 3000 3567 - Freezing, non responsive programs

toesbin,

Click the link below for information to troubleshoot Windows 10. You also may want to restore the system to factory conditions if the below steps do not resolve the issue.

Troubleshoot Windows 10

Other things that may resolve the freezing.

Increase Virtual Memory
Virtual Memory is supposed to act as a savior where the physical memory (RAM) runs out when running resource intensive programs. To compensate RAM, Virtual Memory combines the RAM with TEMP Storage on your Hard Disk. Many users have reported that there freezing issue was fixed by increasing the Virtual Memory to 8 GB.

To increase VM (Virtual Memory), Hold the Windows Key and Press R. Type sysdm.cpl and Click OK.  Then click Advanced -> Settings -> Advanced -> Changed. Uncheck Automatically Manage paging file size for all drives, and choose Custom Size. Set Initial Size to 1000 and Maximum Size to 8192. Then Click OK and Reboot the PC.

Turn Off Fast Startup
Right-click on the Start Menu button to open the WinX Menu.
Click on Power Options.
Click on Choose what the power buttons do in the right pane of the window.
Click on Change settings that are currently unavailable.
Uncheck the checkbox beside Turn on Fast Startup (recommended), thus disabling it.
Click on Save changes.

 



 

0 Kudos