arjarj
1 Nickel

New XPS15 - how to turn off awful window snap menu

 Ok, so my new XPS 15 was just delivered. How do I turn off the awful control that pops up above the title bar when I drag a window. I assume it's Dell crapware as I'm very familiar with Windows 10 and have never seen it before. The control pops up when you try and move a window by dragging the title bar. It tries to snap your window to the side of the screen.

20 Replies

RE: New XPS15 - how to turn off awful window snap menu

Hi,

Thank you for writing to us!

Kindly follow the steps below which will help turn off snap menu.

To turn Snap on or off

  1. Open the Make the keyboard easier to use page by clicking the Start button Picture of the Start button, clicking Control Panel, clicking Ease of Access, clicking Ease of Access Center, and then clicking Make the keyboard easier to use.

  2. Under Explore all settings, click Make the mouse easier to use.

  3. Under Make it easier to manage windows, do one of the following:

    • To turn Snap off, select the Prevent windows from being automatically arranged when moved to the edge of the screen check box.

    • To turn Snap on, clear the Prevent windows from being automatically arranged when moved to the edge of the screen check box.

  4. Click OK.

Thanks

Robin

DELL-Robin D
Social Media Support
#IWork4Dell

arjarj
1 Nickel

RE: New XPS15 - how to turn off awful window snap menu

Robin,

The settings you gave are for the Windows 10 built in snapping feature. I'm perfectly happy with that. What I want to disable is the Dell addin that was pre-installed in Windows 10 on my brand new XPS 15 9550 (delivered yesterday). I've shown in red on the photo the control I'm referring to. It is not part of the default Windows 10 controls. By the colour of the icons I assume it's a Dell addin of some sort. It is the most awful thing I've ever come across. I really need to disable it. I deliberately buy Dell because they don't install any useless addins and crapware, but this totally spoils they whole experience. It appears whenever you try and move a window by dragging the title bar.

Andrew

d3msd8le
1 Nickel

RE: New XPS15 - how to turn off awful window snap menu

Here's the fix.  Run the "Dell PremierColor" app.  Click "Advanced" in the upper right.  Then on the left panel, click "Display Splitter".  Unckeck the "Display Splitter on" box.

Done!

arjarj
1 Nickel

RE: New XPS15 - how to turn off awful window snap menu

Oh yes, there it is. That's fixed it, many thanks!! Who ever thought that option was "adding any value". You really need to ensure this option defaults to off as it totally ruins ones ability to drag windows around.

Many thanks for finding that, I was just about to return the laptop.

Andrew

kbrokaw
1 Copper

RE: New XPS15 - how to turn off awful window snap menu

Here's the fix.  Run the "Dell PremierColor" app.  Click "Advanced" in the upper right.  Then on the left panel, click "Display Splitter".  Unckeck the "Display Splitter on" box.

Done!

thank you SOOO much!!!

Who told Dell this was a good idea?? At least being turned on as a default.

Terrible gadget!

abduwani
1 Copper

RE: New XPS15 - how to turn off awful window snap menu

I agree!


This tool from Dell just ***!

peifferj
1 Copper

RE: New XPS15 - how to turn off awful window snap menu

Thank you!!!!!  I have been trying to figure out how to get rid of this horrible "feature" since I got my XPS15.  When buying a new computer I used to just reinstall Windows to get rid of garbage "features" like this -- probably should have done that with the XPS15.  Thank you again for posting the answer!

Highlighted
zhngmm
1 Copper

RE: New XPS15 - how to turn off awful window snap menu

thanks for posting this, it drove me crazy last night when in hurry to finish some tasks

MiloDC
1 Copper

RE: New XPS15 - how to turn off awful window snap menu

No kidding.  Had my XPS 15 for a month before I decided I couldn't take this *** any more.  I guess some genius thought it was too much work to drag window over to the edge of the screen.

Glad I Googled the way to get rid of this godawful feature.  I never would have thought to look in the PremierColor app.