Windows 10

2 Bronze

Waves MaxxAudio Service Application take 70-90% of CPU

I bought a new Dell Inspiron 13 recently with an i5 7th gen CPU. Interestingly, the fan runs all the time. I realized that even just browsing youtube was causing this so I looked at the Task Manager. There I realized that if any application has any audio playing then there were two tasks that each consumes about 40% of the CPU all the time.

These applications are Waves MaxxAudio Service Application. What do I need to do to resolve this problem? I confirmed that my Windows 10 is updated. Anything else I can do fix the audio drivers or some software?

Replies (21)
5 Rhenium

I have been checking my system and waves only uses about .1% of cpu while playing Youtube.

I would suggest you have the latest driver.  If you already do have the latest one, you might switch to using the Resource Monitor to see if you can break out one particular part of the process.

I have found a couple of websites which will run my processor heavily for no obvious reason..


XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
2 Bronze

Thanks. I updated my drivers to the latest and rebooted. The problem seemed to go away for a few minutes but came back. Resource monitor shows WavesSvc64.exe taking up all the CPU.

5 Rhenium

It might make a difference as to which browser you are using to view YouTube.  I am using IE and even when I plug in a headset it only jumps to 4.6 % momentarily.  

If it is running that much, you might try and watch what happens, to End the Task on those services.  If you want to use the Resource Monitor you can stop the service and restart it.  But doing either one of these you may end up having to reboot to get the operation back.

Try different sites in case the one you are using is involved in the problem.

I have the driver which has the checkbox to disable the popup.  The earlier drivers did not have that option.

I had a situation where a service, which normally uses only 8 threads, was using around 1400 and causing high processor usage.  It as caused by the Audiodg.exe file and it seems it was waiting to play a system sound.  It doesn't sound like yours is doing that exact things, but there must be something causing that much extra usage.

I don't have any systems with an i5 processor.

XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
2 Bronze

Thanks again. Good point on more testing. I tried with Edge browser and different websites. Then I tried music and video files on the laptop (not in a browser) with VLC player. They all had the same issue. High CPU usage by Waves Maxxaudio process.

5 Rhenium

What happened when you ended that process?

I have heard some bad things about VLC.

I think I would uninstall VLC and all the prior Realtek drivers.  Then just reinstall the Realtek driver.

When you install a Realtek driver, it uses a .inf file to install the components.  You may have more than one of those on your system.  You can use Device Manager to remove the Sound Device and check the box to remove all drivers.  Do that as long as while offline it reinstalls a Realtek version.  When you get to the basic Microsoft driver, then you can reinstall the Realtek driver you downloaded.  Do this all offline.

Also, check the Programs and Features dialog from the bottom of the Settings-Apps page to see if any Waves software can be uninstalled from there.  You may look for Realtek software but Reatek may have software for other types of devices.

XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
2 Bronze

I just tested reverting to the standard Windows Realtek drivers by doing this:

  • Open Device Manager
  • Go to Sound, video and game controllers
  • Find Realtek Audio
  • Right-click, then click update driver.
  • Select "Browse my computer for driver software"
  • Click on "Let me pick from a list..."
  • Find the device "High Definition Audio Device"

It will warn you that it can't verify that the drivers will work. Just say ya, ya, ya intil it proceeds. It will switch to the default Realtek drivers and require a reboot. On reboot the waves driver will be gone, along with the prompts. 

Headphone audio should be improved but speaker volume may appear lower due to the lack of compression. I found a bit of apparent distortion on the speakers with the default drivers.

I too experienced this issue with CPU being maxed out by the Waves Audio Services. I just disable it from the services and the problem goes away. Just do a search for "Services" and scroll down to "Waves Audio Services". Then change the "Startup Type" to "Disable" and stop the service by clicking the "Stop" button and click "OK" and close the window. The sound still works and your CPU is not taxed anymore.

Looks like mining cryptocurrency.
It is very strange to load the CPU  (  there is an sub-processor for audio )  when the Internet is connected.  I will assume that their programmer, embedded in the code the extraction of currency for himself. But this is only a guess.

Same issue!!! 90% CPU usage always when playing sound only, Other programs got slow due to the issue I sometimes regret buying core i5 7th generation laptop. I have inspiron 15 laptop
Top Contributor
Latest Solutions