Highlighted
majorityspoon
1 Copper

how to boot usb in uefi mode (not legacy) for inspiron 3531

Tried various search terms, but nothing came up. Upgraded to windows (from factory default windows 8) 10 while it was still free. Wiped the drive and tried to reinstall windows 10 (home) and all I got was an error saying that can't install on non gpt partition. Turns out the only way can figure out how to boot usb is via legacy mode. Plugged hard drive into desktop machine and says all the partitions are in fact gpt. Used rufus to burn image to usb, made sure that is gpt as well. For fun, tried the system restore function, but fails right away. I just deleted the windows partition (not the entire drive). Was playing around with settings in the bios: Insydeh20 setup utility. gpt option (usb) - select option Get his popup -> input file path?
2 Replies
Saltgrass
4 Ruthenium

RE: how to boot usb in uefi mode (not legacy) for inspiron 3531

When you reinstall there are some critical partitions.  You cannot leave any of those of the drive and reinstall Windows 10.  Data partitions should be OK.

To boot a USB drive as UEFI, assuming your system has that capability, you have to format the USB drive as FAT 32.  It must use an x64 bit version of Win 10.

When you boot you should be able to see a Boot Device Menu.  Look for something that shows as UEFI and boot to that.  If you don't see a UEFI option, the Bios may be set incorrectly or the USB drive is not configured correctly.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

Anil Kushwaha
1 Copper

RE: how to boot usb in uefi mode (not legacy) for inspiron 3531

Your solution really worked for us as I was searching on internet and we had also opened a thread with Dell but they didn't give any solution. From Dell, this case has passed through 3 technicians but there is still enigma for them.
Thanks Man for a quick fix.

0 Kudos