Windows General

Last reply by 01-20-2023 Unsolved
Start a Discussion
3 Argentum

Alert to Dell latitude 3520 about BIOS update

Latitude 3520

I highly recommend doing not update the bios to v1.22.0 of your laptop dell latitude 3520 (i7 / 11th) ...
Today i update to BIOS version (Latitude_3420_Latitude_3520_1.22.0.exe) and when the pc started the update, stuck on - 0% saving manifest - and after that i wait for 4h and nothing happened ... i tried to shut down but ... until, i plug out the charge of my PC and battery discharged ... and the happy news that i still access to recovery mode of bios ...

Replies (51)
2 Bronze
2 Bronze

Hello there, I’m currently facing this issue at the moment. Was the laptop loading to OS when you restarted it later? Or did it fail? 

2 Bronze
2 Bronze

Hello there just to give an update.

I had contacted dell support and they had asked me to manually remove the connector from battery to mb

After this I drained the excessive charge from all the components by holding the power button of the laptop for 1.5 minutes

Then I rebooted the machine and it worked

however I would not suggest anyone to try the above steps without an official consultation with a dell certified support engineer or agent



Thank you for contacting us.

To ensure the privacy of your information, please send us a direct message, and we will be happy to assist you in resolving your computer issue.

Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. To send us a private message, click our DELL-Cares username. Our Forum profile page will then appear. On the right, click "Send this user a private message".

2 Bronze
2 Bronze

We are facing this issue with our customers. Update have been deployed via Dell Command Update and same symptom...

Asking users to take off back of the computer and disconnect the battery is not an option at all!

We will have to wait for battery to drain completely to be able to boot again. I can't understand this lack of communication from Dell!

2 Bronze
2 Bronze

facing the same problem here, on a brand new Dell Latitude 3520, after downloading and installing the BIOS update using Dell Update..... I'm currently waiting for the battery to drain out, in the hope that after the boot you can gain access to the computer:


2 Bronze
2 Bronze

Same issue over here on our Dell 3520 laptops.  BIOS update fails and gets stuck on 0% "Saving Manifest".  Holding power button does nothing.  

2 Bronze
2 Bronze

remove back cover unplug the battery. hold power button 10 secs. plug back in, assemble, reboot

2 Bronze
2 Bronze

@cmoore96 yes that seems to resolve it, not ideal when you have hundreds/thousands of devices out with end users who you wouldn't want to be dismantling a laptop.


i remember when you could pull a battery out of a laptop and when you could change a keyboard without tearing the whole thing to 10000 pieces

Latest Solutions
Top Contributor