Windows General

Last reply by 01-20-2023 Unsolved
Start a Discussion
3 Argentum

Alert to Dell latitude 3520 about BIOS update

Latitude 3520

I highly recommend doing not update the bios to v1.22.0 of your laptop dell latitude 3520 (i7 / 11th) ...
Today i update to BIOS version (Latitude_3420_Latitude_3520_1.22.0.exe) and when the pc started the update, stuck on - 0% saving manifest - and after that i wait for 4h and nothing happened ... i tried to shut down but ... until, i plug out the charge of my PC and battery discharged ... and the happy news that i still access to recovery mode of bios ...

Replies (51)
2 Bronze
2 Bronze

the power went of by ityself. now I connect the AC power again, press power button,  and get this screen, BIO Auto-Recovery

what can I do?


2 Bronze
2 Bronze

after a few attempts, the screen suddenly jumped to another update screen, it was quick, I could see a progress bar reach 100%.  Then it entered the BIOS Setup. I picked the Continue button, then it did a reboot and now everything is ok. I didn't disconnect the battery. It's really a weird situation.
Solved but I highly recommend DO NOT UPDATE THE BIOS and check Dell Command Update carefully. before installing any updates. Current BIOS installed : 1.22.0


Can we get a response here in the chat? I have multiple users experiencing this issue after firmware updates.

2 Bronze
2 Bronze

Looks like "dell cares support chat" is pretty toothless if you don't have a way to send them information that you can't get without booting to windows.


2 Bronze
2 Bronze

Ok, well when you get to Humans in there they are trying to help, but it seems that this is "one of those" problems. Last recommendation was to let battery drain out. So don't bother them, they have more easier problems to fix.

But waiting takes too long... so next thing

If you have never opened a laptop, I would not recommend, and I didn't like how fragile the battery connector looked like.

After returning mains power to laptop, it seem to go forward almost instantly, so it leads to believe that everything critical has already been done before. So there seems to be very low risk of powering down causing extra damage to bios data.

Also, if you support multiple these laptops, maybe remove automatic updates for dell command. Why upgrade BIOS, if it's not broken.


<Shrug> This was a risk of unnessesary upgrades happenstance.


I've got a user stuck here as well, drained the battery overnight, but still nothing. Can't have him remove the back case and disconnect the battery. for him, sadly it's a bricked workstation and I've got to ship him a new device.


If longer charging of battery won't resurrect it, then you would be first to report bricked (completely unrecoverable) device from this update. I'd be more hopeful that it remains temporary. Charge completely full overnight / overday.


I'm able to load Windows, but Office products are not able to sign in due to a TPM error.

2 Bronze
2 Bronze

I was able to get into the BIOS for one of our devices and there are no options for the TPM module to enable or anything


plug ac power and wait till it over 20 then retry .... it will fix and reboot by it self...

Latest Solutions
Top Contributor