Windows General

Last reply by 01-20-2023 Unsolved
Start a Discussion
3 Argentum

Alert to Dell latitude 3520 about BIOS update

Latitude 3520

I highly recommend doing not update the bios to v1.22.0 of your laptop dell latitude 3520 (i7 / 11th) ...
Today i update to BIOS version (Latitude_3420_Latitude_3520_1.22.0.exe) and when the pc started the update, stuck on - 0% saving manifest - and after that i wait for 4h and nothing happened ... i tried to shut down but ... until, i plug out the charge of my PC and battery discharged ... and the happy news that i still access to recovery mode of bios ...

Replies (51)
2 Bronze
2 Bronze

I was facing with this problem too.

Dell suggested me to

1. unplug the AC adapter

2. remove the base cover

3. remover the battery cable

4. re install the battery cable

5. re install the base cover

6. plug in the AC adapter

7. button power on

8. the laptop go through the BIOS recovery

then the problem solve.

2 Bronze
2 Bronze

I've just had an update from support to say this BIOS update has now been pulled and a new one is due to be released.

Community Manager

The team needs clarification from all.

Does the issue happen by installing the update from within Windows -and/or- by installing the update via the restart, F12 menu?


DELL-Nathalia M
Social Media Support, Community Manager

(If this reply helped you solved the issue, please remember to click the option Accept as SolutionSe a resposta recebida ajudou você a resolver o problema, lembre-se de clicar na opção Aceitar como solução.)


@DELL-Nathalia M 


While using Dell Command within Windows.

Have not tested this via F12, who uses those anymore.  

I have one still on old version, I could try that tomorrow.

Please pm me a link to bios file, as version was pulled/hidden from public. (latest I see 1.20.0 versus 1.22.0)


Community Manager

BIOS update 1.23.2 was released today and can be downloaded here. Please let us know if there are any other issues with the latest update. 

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag

2 Bronze
2 Bronze

Updating from 1.20.0 to 1.23.2 ; It works ok.

Used executable to update and took about 3 minutes to actually flash. I had only 2 modules to update, "BIOS" and "BIOS connect". Manifest was saved in a blink of an eye.  


thanks all


Glad to hear this, thanks for the update!

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag


Omg ! today i update my bios and stuck on Saving manifest 0 %


My laptop battery will died after this second failed update !

2 Bronze
2 Bronze

We are facing this issue today. We were prompted with a popup that our laptop required updates, and we selected the recommended firmware and BIOS update. Now we have this same issue and are waiting for the battery to die per the recommendations in this thread. This is impacting our employee and support staff and is hugely disappointing. 

Latest Solutions
Top Contributor