Windows General

2 Bronze

Cant seem to install programs onto my pc

I was recently having problems with downloading a simple music software which i had before when i went to download it, it wouldn't download. recently i just tried to download league of legends ( a game ) its a safe game, but everytime i go to download it appears on the bottom then when i go to click on it, it doesnt appear and just ends up dissapearing and then a red lock icon and i read up on the red lock icon and it apparently means Google Chrome knows there are problems with the site's certificate. Proceed with caution, because someone on your network (like someone sharing your wi-fi connection) might be messing with the website. If you disclose any information on the website, the person on the network might be able to read it. but no other person is controlling with it, not that i know of.

Replies (6)
5 Tungsten

Hmm... you might want to reset google chrome.  Click on the 'hamburger' icon on the top left (looks like 3 lines), then click on settings.  In the new window, scroll down and click on advanced settings, and then all the way down at the bottom is reset chrome.  See if that works.

10 Diamond

Check your system's date and time.  If your system date is set to the past or future, you'll see those certificate warnings.

2 Bronze

Just tried, it still doesnt download unfortunately

2 Bronze

So guys the little red icon has turnt green now, so thats gone away however the program still wont download!

10 Diamond

What are you trying to install?

9 Rhodium

No it means the site doesn't have what you want it has malware instead.

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support


Get Support on Twitter @DellCaresPro


Diagnostics & Tools

Top Contributor
Latest Solutions