Windows General

Start a Discussion
2 Bronze
2 Bronze

Installed RAM 16GB, only 4GB in BIOS - Precision T5400

Hi all,

I am at wit's end trying to get the most of my memory upgrade.

I am running 64-bit Windows7 on Dell Precision T5400 single quad-core Intel Xeon E5405. Motherboard 0RW203. BIOS version A11

Got eight identical sticks of 2GB ram (totaling 16GB) and installed it on all available slots. Noticed on Windows properties - Installed RAM 16GB (4GB usable). Tried to play around with virtual memory allocations, but no success.

Checked BIOS and it showed all 8 slots occupied with 2GB ram, but installed memory is 4GB. Don't see any options to tweak BIOS setting for it to recognize all 16GB ram.

Checked each stick individually and all play nice and the CPU-Z reports them installed as well, ruling out slot or motherboard issue. I suspect its a BIOS issue and I would be grateful for anyone who can suggest a solution.

I will be happy to provide additional information as requested. I inherited the machine, so RMAs and returns are out of question.

Replies (23)
2 Bronze
2 Bronze

Hi all!

It looks I'm having the same issue here.

I tried all possible memory configurations and in MOST CASES bios fails to detect half of the memory.

BUT SOMETIMES it detects all memory if on boot prompt strike F1,  unfortunately as soon as you go to BIOS it either crashes or decreasing memory to half

As I can see it's about 2 years since question was raised. If anybody from DELL found a time to sort it out or if anybody managed to find the solution?

thanks

2 Bronze
2 Bronze

ok

here is a temporary workaround 

on my example

Originally I had installed 4 GB / 4x1GB in slots 1-4 (white ones)

I wanted to upgrade to 16GB / 8x2GB

And obviously had a same problem as topic starter

But I managed to work all memory in following way:

  1. install back old memory and let the bios recognise it
  2. reboot and turn off pc
  3. install new memory (16GB / 8x2GB)
  4. after turning on you will see the message "memory size changed"
  5. strike F1 to continue and just forget about BIOS existance, because as soon as you go there, the chances are your memory will be decreased

Clearly it is a BIOS bug.

I'm using A11. 

For DELL It would be really nice to fix it at last

Community Accepted Solution
3 Argentum

Firstly have you installed the correct configuration of memory?

http://downloads.dell.com/Manuals/all-products/esuprt_desktop/esuprt_dell_precision_workstation/prec...

Follow page 187 - 188 - compare the specifications written on the memory Vs whats given in the manual. 

Also 32 bit OS addresses only 4 GB of RAM, show 3.25 GB in Windows 4 GB in BIOS. 

Mark my answer as resolved if your issue is resolved

Best Regards,

VeejDeej

Endorse me: http://goo.gl/C3567
Dell user

I know this is a really old thread, but I wanted to post how I got all 8 DIMMs recognized. 

Recently someone gave me one of these old workstations when he cleaned out his garage. It had 8 PC2-5300F 1GB DIMMs (DDR2-667 FB-DIMMs) populated in all 8 sockets, but curiously the BIOS would only address 6GB of RAM in dual channel mode. All of the DIMMs were identical; same manufacturer, same speed rating, same voltage, but I still could not get it to address the DIMMs in sockets 7 & 8. 

Finally I had an idea. If I slowed down the memory bus somehow, maybe the memory controller could then handle all 8 DIMMs. So I put 2 PC2-4200F 1GB DIMMs (DDR2-533 FB-DIMMs) in RAM slots 1 & 2. And then all 8GB of RAM was addressed in BIOS, and available in Windows 7. And as a bonus, it was addressing all 8 DIMMs in quad channel mode. The only downside is that it was working at 533MHz, but it was now in quad channel instead of 667MHz in dual channel. Overall a net gain, especially when you consider the 2GB of RAM I reclaimed.

Obviously, your mileage may vary and this is probably not a memory configuration recommended by Dell. But I'm happy to have all 8GB of RAM working now.

============================
Precision T5500, Inspiron Gaming Desktop 5675, Inspiron Gaming Laptop 7567

I need help. Seriously. I had 6 4Gb ram modules in my T5500. At some point, the identified ram was only 12Gb. I figured, I’ll just buy new ram. I wanted to maximize what the computer could take which is 72Gb. Bought it, cleaned out the whole box. (Do that every 6mos or so). Installed the ram and got a DIMM 3 error. Replaced the battery CR2032 for the CMOS. Ran all the tests and everything seems to come back okay. I’m at a total loss. Updated the BIOS to A18. Not sure what to do? Should I buy a new motherboard? Seen one on Newegg OEM dell for 98.00.... will that fix my computer?

if anyone can help I would really appreciate it. Not sure how to tell if the sockets are good or bad?

 

64 bit os is required along with the INTEL CHIPSET Drivers.

https://downloadcenter.intel.com/download/20018/INF-Update-Utility-Primarily-for-Intel-6-5-4-3-900-S...

https://downloadcenter.intel.com/download/20104/Intel-Rapid-Storage-Technology-RAID-for-Intel-5-Seri...

 

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support


Get Support on Twitter @DellCaresPro


Diagnostics & Tools

I know this is very dated but still a real issue.  What Arsenal76 posted is the most viable solution.  Ignore the bios and just power through with F1.  I also had DIMM 3 memory error, but I tried installing the upgrade one stick at a time, after returning to original config.  Power on, go through the F1 option, check windows - computer - system to ensure the correct memory is there (it was). Then shut down, add a stick and repeat.  I noticed when I just added one stick it wouldn't give the error message.  I also noted that when I was adding all the memory and going through the countless combinations to figure out the problem, that the first DIMM slot that had a new module would be the one reporting error.  But when I added one at time, as above, fully recognized/available/installed and no error message.  Weird but true.  Return it to the original config, turn it on, bypass the bios, and then off, install (in my case I was adding memory) new stick, turn on, bypass bios.... rinse, repeat.

This machine (T7500) has so much going on that these simple solutions seem to fix the problems rather than more complex solutions, especially if things had been working, prior.  Thanks Arsenal76 !

2 Bronze
2 Bronze

I believe it's a motherboard issue. I have 2 T5400's. One is working great with 32gb of ram 8x4gb running on Win7 64 bit. 

The other is also Win7 64 bit. I had a problem with some 1gb memory in slots in 7 & 8. I took out the RAM leaving the machine with 6gb. I recently bought 16gb (8x2gb) to upgrade that machine. 

I loaded it up with 16gb, started it up and started getting a beeping from the Motherboard. Started troubleshooting. Narrowed it down to memory slot 7 & 8. It won't recoginize anything over 1gb of ram total. I had 2 old 512 sticks. I put those in. Came up fine. BIOS recognized it. Worked fine. Changed that out to 1gb sticks. Same MB beeping issue.

You might not have the beeping, but if each slot is only utilizing 512mb of RAM regardless of what the BIOS says is installed, then your max memory would be 4gb. You can get a replacement MB for relatively cheap. I suggest that route.

Hope this helps.  

2 Bronze
2 Bronze

I've seen some follow ups.

Whoever reads it please do not mind comments about incompatible memory or 32/64 bit systems.

Just follow my procedure and it will help

So far I'm happily using all of 16GB

2 Bronze
2 Bronze

My 2 cents,

I've refurbed at least 100 x T5400/T7400 to date. FB RAM is cheap so upgrading to 16/32GB is affordable & easy.

Bear in mind that the machines probably had much less at new and, crucially, not all DIMM slots filled...

My point is that DIMM slots get dirty.  MAKE SURE you give each slot a proper clean with appropriate solvent and air and inspect for debris.  I have had at least a dozen PCs baulk at initial RAM upgrade only to find after a thorough clean all works as expected. (Obviously make sure the RAM sticks are clean too!)

Also follow the recommended population routines ( stated a few posts above) if you are NOT filling every slot.

Hope that helps!

ATB

Top Contributor
Latest Solutions