Windows General

Last reply by 07-15-2015 Unsolved
Start a Discussion
2 Bronze
2 Bronze
191075

Is it possible to run win98 on a Dimension 4600 ???

My Dimension 4600 came with XP, since I wanted win98, I've reformatted the hard disk and installed win98

Installation went fine, however, when starting win98 for the 1st time, I had to install a few drivers so that win 98 would recognize all the hardware.

I installed the nvidia geforce driver for my video adapter, but there's no way I can get that driver to work (conflict with ACPI bios memory range)

I also discovered a similar conflict with one of my USB device that I disabled, but I'm now wondering: is it possible to run win 98 on a dell dimension 4600 ???

How can I get my geforce 5200fx to work??? anyone?

Replies (32)
8 Krypton
2792

al646,

The proper NVidia driver for Windows 98 can be downloaded from here. Because Windows 98 is nearing the end of its supported life, it is possible that some hardware will not be compatible with it. You will find that nearly all software written for Windows 98 will run under Windows XP in compatibility mode so returning to Windows XP will be the most painless solution to your problem in the long run. If you have DOS program which will not run under Windows XP consider running Windows 98/Windows XP as a dual-boot system.

2 Bronze
2 Bronze
2792

Thanks for your answer, I just wanted to add that I already configured my machine for dual boot, win98 on C: partition and win xp on e: partition. This is because I have a few programs that won't run under XP.

 The driver I used for my nvidia geforece fx5200 is already the one found on the nvidia web site since Dell does not provide win98 drivers for their PC's

When I installed the nvidia driver, I came up with the following problem:

Nvidia GeForce FX5200 conflicts with

Memory range 00000000-00ffffff used by system board extension for ACPI BIOS

Same for memory range 00000000-07ffffff, 000c0000-000cf7ff and 00000000-0001ffff

Even though win98 is nearing end-of-life, almost all computer manufacturers still support win98, as well as all related hardware vendors (eg: nvidia)

It would be a real shock to hear from Dell that my new Dimension 4600 can't run win98...

Thanks for helping

2 Bronze
2 Bronze
2791

I fear that as it stands it will not be possible. I have exactly the same problem you do.

Specifically, if you look in the

Control Panel > System > Device Manager > Computer > Properties > Input/Output (I/O)

you will see that something called

Alias of Intel(R) 82801 Ultra ATA Storage Controllers
Alias of Primary IDE Controller (dual fifo)
Alias of Intel(R) 82801 Ultra ATA Storage Controllers
Alias of Secondary IDE Controller (dual fifo)

has consumed a lot of the I/O slots to the exclusion of the video. These four entries are repeated at least 120 times (I quit counting at that point).

I believe this to be because Dell does not include in its BIOS an opportunity to change the mode of the ATA controller from "enhanced" (includes serial ATA) to "legacy" (Standard IRQ 14/15) supported by older OSes such as Windows 98/95 etc. This issue may extend as far as WinME.

I am sitting staring at two brand new just out of the box 4600 (s). Dropped a second drive in, installed Windows 98SE fresh. No Joy.

(As an aside, I think I put two 4550 or 4600 into an office ten days ago, and didn't have this problem. The difference is that these have drives transferred from older machines, with new device drivers where neccesary. I have to check. This process was required for compatibility with other existing machines in that office, AND it was a rush job. Works.)

If anyone knows how to get Word 97 to print identically whether on (Windows 98SE or Windows XP) to a HP LaserJet 4Plus, (line wrapping different in long documents) my problem would go away.

I know ... idiocy.
2 Bronze
2 Bronze
2791

This is VERY frustrating, I've contacted Dell Support to see if they can help...

I've also found this on the internet, do you think this could help resolve the problem????

ACPI active can be the source of problems in
                      Win98SE.  Windows 98SE automatically installs in
                      ACPI mode if an ACPI BIOS is detected.
                      Unfortunately, Win98SE does NOT handle ACPI very
                      well and IRQ sharing with this OS is problematic.  If
                      USB is sharing its IRQ with IRQ Holder for ACPI
                      Steering and several other devices you will need to
                      install the OS in APM mode as outlined below.

                           Reinstall Windows by starting the system using
                           the boot floppy with CDROM support. 
                           From the A:\ prompt start Windows from the
                           CDROM
                           D:\setup /p i when D:\ is the drive letter of the
                           floppy.
                           If your hard drive is running from a High Point,
                           Promise or ATA 66 or 100 controller, the drive
                           will not be recognized at boot up and you will
                           need to come back a letter.
                           A clean reinstall is recommended

2 Bronze
2 Bronze
2791

These problems could be related. The lack of flexibility in the normal Dell BIOS setup creates a closed loop. Work arounds for these types of problems don't exist unless the BIOS is optioned up. But they have control and warranty issues if end users just start tweaking for performance or compatability. I have seen the USB issue repeatedly, but it has never caused this kind of problem. I am usually able to ignore USB issues, as I don't put those peripherals on standard office machines yet. (All hail the PS/2-ported keyboard and mouse).

I guess I need to sit here and run the obvious experiment.

Should take about two hours.
2 Bronze
2 Bronze
2791

You seem to be very knowledgeable about this issue, thanks for your help, what surprises me most is that nvidia offers win98 drivers for their graphics adapters and most system have no problem running win98 with nvidia geforce 5200, I'm just wondering why it's just the Dell 4600... If it's only a BIOS issue, Dell should be able to help... unless we find a solution before them ;)

 

2 Bronze
2 Bronze
2791

Knowledgeable by desperation. If I can't make this work I have to explain to people I would rather not have to explain to.

As it turns out, the two other machines were 4550 , not 4600.

 

However, After scratching around for several hours, this is where I am.

Format drive.

In BIOS, turn off UDMA. I don't know if it makes a difference, I was just trying to kneecap all the higher order functionality I could see in the BIOS. All other devices are in their default settings.

If found this on Google:

//begin google//

Try setup /p i to force no ACPI.

You do not have to disable ACPI in windows, do it in the bios.  Windows will
follow accordingly.

Windows relies on the bios for initial irq settings, whether ACPI is enabled
on the system or not.

Some simple bios setting manipulation, and moving cards in slots, resetting
configuration data, can reset irqs to something easier to live with.  Some
motherboard's bios incorporate both ACPI and PNP OS into the one PNP OS
setting with no ACPI setting.  Disable this.  I found its easier to work at
the bios level with irq manipulation.  After accomplishing irq manipulation,
you may enable ACPI with bios settings.  Windows will follow suit, but may
show sharing of something not noted in bios setup.  Ignore this, its bogus.

For power management, sometimes windows just does it best.  Turn off power
management in the bios.

// end google //

 

Some of it applies, some of it doesn't.

 

I did a fresh install of 98SE  with this line:

e:\win98\setup /p i

During the install I selected the minimum install.

 

Install completed, and the Std VGA was installed, unlike before.

Installed the nVidia drivers from their web site.

Works.

Not sure why, except that the PNP BIOS is getting information from the hardware and not the BIOS.

 

I still have to get the other devices installed, but I am hopeful.

 

Good Luck

 

2 Bronze
2 Bronze
2791

Wow, sounds great!

To make sure I understood and summarize what you did:

1) Disable UDMA in BIOS

2) Install Win98 with this line (minimum install)

e:\win98\setup /p i

3) install nvidia driver + other drivers

Question: once you're all done, should you keep UDMA disabled? Since I'm dual boot, what's the impact of UDMA disabled on my XP partition?

Thanks a lot for your help, really appreciate :)

2 Bronze
2 Bronze
2791

Hi,

I just reinstalled win98 from CD using setup /p i and it worked even though I didn't change any BIOS settings. I simply reisnatlled win98, no bios change, no nothing, except the /p i switch in the setup command. I didn't even bother do make a clean install.

I installed the nvidia drivers etc, and finally came up with win98 fully operational... well, that's what I thought until I noticed that I was missing the PCI Universal Serial Bus driver... any idea where I can find this driver?

I also have a conflict with my USB controller (Intel 82801 EB USB host controller), but I guess the driver would help...

 

Latest Solutions
Top Contributor