Highlighted
cGt 2099
Bronze

Latitude E5400 - Unknown devices listed in Device Manager

Hey guys,

 

We just got a shipment of new Latitude E5400's here.  I started working on one, reformatted and installed a clean fresh copy of WinXP (SP2).  I followed up by installing the device drivers in the correct order as recommended by Dell.  

 

However, I have a list of unknown devices listed in the Device Manager. They are as follows:

 

Audio Device on High Definition Audio Bus

Base System Device

Fingerprint Sensor

Modem Device on High Definition Audio Bus

SM Bus Controller

 

The Audio Drivers have already been installed, despite the listing above...

 

I have a feeling it has to do with the Chipset drivers, or perhaps some drivers are not listed for this machine on support.dell.com?  

 

Please advise.

 

Regards

 

Greg Davies

Cameron University

0 Kudos
3 Replies
cGt 2099
Bronze

Re: Latitude E5400 - Unknown devices listed in Device Manager

The situation has been resolved.  Thanks.  Please close/delete this thread. 
0 Kudos
pgcpsittech
Copper

Re: Latitude E5400 - Unknown devices listed in Device Manager

What was your resolution for the "Audio Device on High Definition Audio Bus"? I've been talking with customer support and researching for hours with no success.

0 Kudos
bumper314
Copper

Re: Latitude E5400 - Unknown devices listed in Device Manager

I too have an issue with these unknown devices:

 

  • Audio Device on High Definition Audio Bus
  • USB Hub

 

So none of my USB ports are working, despite having all the drivers installed.

The speakers work but I assume the unknown device is the microphone.

Any ideas?

0 Kudos