1 Copper

Optiplex 760 AHCI Imaging Problem

I'm having a problem imaging our new Optiplex 760 in AHCI mode.  I can image the workstation when I set the HD to ATA mode in the BIOS.  I can also set the BIOS back to AHCI mode after imaging (of course, I update the following devices with the newest driver.)

What happens is the following:

  1. With the BIOS set to AHCI mode, I boot the machine from a Bart's PE USB drive.
  2. I run ghost and image the machine with XPSP3 that includes all of the drivers needed.
  3. Reboot the machine and the Windows logo with the blue status bar appears.
  4. The machine freezes, and reboots itself into the safe mode selection screen.

What I have found so far is that the following devices are new for this system: (I think these are the culprit)


I have edited our sysprep.inf file to include the following in the [SysprepMassStorage] section:


The location c:\sysprep\massstorage folder contains the latest Intel Matrix Storage Manager drivers.  I've tried the one on Dell's website (Version, A15) for the 760 (Windows XP) and I've also tried the newest driver directly from Intel.  The location c:\sysprep\massstorage\old refers to the previous device drivers for devices that aren't included in the new driver.  This allows us to image all of the devices we currently have from Dell (D400-D430, D600-D630, D800-D830, E4200, E4300, E6400, E6500, Optiplex SX & GX 270, 280, 620, 745, 755 and now 760.)  All of the devices that I listed except the Optiplex 760 are currently imaging fine in AHCI mode (where applicable and ATA mode where not.)  We use Bart's PE as our boot environment and I can boot fine in AHCI mode.

I assume my problem is I'm either not listing a device in the [SysprepMassStorage] section of sysprep.inf...


In the newest Matrix Storage Manager, the iaStor.inf and iaAHCI.inf have the following in the [ControlFlags] section: ExcludeFromSelect=*

I think previous versions of this driver have had a specific list of devices in the list, this one has all devices, hence the "*".

**UPDATE: The ControlFlags section does not impact this issue, it merely removes the device listing from certain user interface displays.  My bad.

Please feel free to post any/all thoughts as I need to have this resolved ASAP.



0 Kudos
16 Replies
1 Copper

Re: Optiplex 760 AHCI Imaging Problem

@Bcamball3 - I'm also working on this same issue.  I'm not using BartPE however.  I'll post up any new informaton.  Unless ofcourse, you've managed to figure it out already...  🙂



Tags (1)
1 Copper

Re: Optiplex 760 AHCI Imaging Problem

Turns out that I just had the incorrect pnp id pointing to the wrong inf file.  Hope you figured out your problem. 🙂

1 Copper

Re: Optiplex 760 AHCI Imaging Problem

The point made by ripht is absolutely essential.

The other essential point about using the [SysprepMassStorage] section of sysprep.inf is as follows:

- Any changes or new lines added to this section will require you to re-run sysprep on your master PC image build.

--- [SysprepMassStorage] is a factory-level stage of sysprep, so you can't just edit the sysprep.inf within the image. You MUST re-apply the updated sysprep.inf by re-running sysprep.exe -reseal [or sysprep.exe -factory] on your master PC image build.

- Note that the iaahci.inf driver from the Optiplex 760 Dell download also supports the pnpids for all AHCI-mode Latitude E-Series laptops.

- Note that the iastor.inf driver from the Optiplex 760 Dell download also supports the pnpids for all IRRT-mode Latitude E-Series laptops.

- Intel Rapid Restore Technology (IRRT) = RAID mode.

0 Kudos
1 Copper

Re: Optiplex 760 AHCI Imaging Problem

I am also encountering this same issue.  I am using DeskAuthority to create and deploy my images.  This is the first time I have ran into this problem.  I can also switch between ATA (which I had to change to install XP) and AHCI but this makes no difference.  What about the BIOS settings for ImageServer?  Any ideas?


0 Kudos
1 Copper

Re: Optiplex 760 AHCI Imaging Problem

What software do you use?  And what settings do you need to change?  Any info appreciated.


0 Kudos
1 Copper

Re: Optiplex 760 AHCI Imaging Problem

I'm also having the same issue as the OP.

I have added the new AHCI drivers to the Sysprep Mass Storage section, I then ran sysprep -mini -reseal and took an image of the computer. I deployed the image to one of the new Optiplex 760s and when it is in AHCI mode Windows will not boot. I have tried using the drivers from the dell site as well as the latest ones directly from Intel with the same results.

If I revert to ATA mode Windows boots fine however this is not desirable as we have 50 Optiplex 760s and I'm not going to manually change each one. I have other models which come in AHCI mode which I have been able to image without issues, so I am assuming the problem is related to the Optiplex 760's drivers, or I am also missing a device in the mass storage section (though I have triple checked...)

If anyone has any ideas I would be very appreciative.

Here are the extracts from sysprep.inf which are relevent.






0 Kudos
1 Copper

Re: Optiplex 760 AHCI Imaging Problem

I worked with a Dell engineer for some time on this issue.  We did not find a solution to the problem.  The problem is most likely that Dell installs a lot of "system software" as part of their standard image.  If I use the image provided by Dell for this machine, it does actually work in AHCI mode.  I have not been able to isolate what is and is not present.  Frankly, I reached my limit on time I was willing to spend on this issue.  We have the workstations shipped in ATA mode and they work fine.  It's extremely annoying to me, but it is what it is.  We're facing the sunset of Windows XP as a standard image in the near term.  I am willing to live with this shortcoming until we deploy Windows 7.  As an IT geek I HATE to let something like this go, but I have bigger problems than this AHCI/ATA driver issue.

To directly address what you are and are not doing, Dave:  I think you're doing everything right.  This is the process that has always worked for me.  I've done Dell imaging in this way for the last three and a half years (since I took over imaging for my company.)  In fact, I did a buildmassstoragesection command too.  This rebuilt the system's SysprepMassStorage section to which I added the exact above lines.  It just doesn't want to work in AHCI mode.  I expect people using different imaging methodology to have different results.  I see some people that are not using the typical sysprep/ghost method were able to make their images work in AHCI.  Lucky you if it works!!  I kind of feel as if I'm not being helped to push me towards vendor imaging.  Unfortunately, there is a cost to vendor-side imaging.  Increased cost is not something my organization can afford at this point!!

So, sorry to say, but I gave up.  I've had other sticking points aside from the AHCI imaging problem.  As Dell adds more and more drivers to their workstations, imaging becomes more difficult.  When new models are released (at least for the Latitude and Optiplex series) drivers fall through the cracks.  New drivers sometime take far too long to get on Dell's website.  I have typically been opening up the Dell case and finding out who makes what hardware.  Then, I go to the manufacturer's website and download directly from them.  I've had better results with the newest drivers... especially chipsets, video and network.  Wireless has been notoriously bad lately.  We've switched wireless hardware Intel after a plethora of Broadcom issues.  Basically, I'm just out of patience!

Feel free to contact me if you want more info!!

0 Kudos
1 Copper

Re: Optiplex 760 AHCI Imaging Problem

Thanks for the info Ben! Not what I wanted to hear but atleast you've saved me from spending any more time on this. 🙂



0 Kudos
1 Nickel

Re: Optiplex 760 AHCI Imaging Problem

I'm struggling with this too. Seems to be a fair few people out there experiencing the same issue, but no one has it resolved yet.

I have a similar section in my sysprep.inf :


I've tried changing this to:


(changing the .inf file referenced for that device ID)

...but it makes no difference. I'm fairly sure the problem is due to the controller with the 3A02 device ID. This is because after I apply my workaround the remaining SATA controller reports this ID.

Anyway, here's my workaround:

1) Image the 760, then before booting XP for the first time change the SATA mode in the BIOS to ATA rather then AHCI

2) Boot Windows, let it run through till you see the desktop. Now use device manager to locate the "Primary IDE Controller" that isn't recognised as an Intel device.

3) Force the driver to update to "ICH10D/D0 AHCI Controller" by pointing it at your Intel Text Mode driver folder, then reboot.

4) Change the SATA mode back to AHCI in the BIOS then let Windows boot back up.


Your SATA controller is now running in AHCI mode.

I'd really like to see a proper fix for this. Looks like the issue lies with the Intel driver for the ICH10 - does anyone know if this works when setting up XP from a CD and pressing F6 to installt the controller?


0 Kudos