Denver_80211
1 Copper

Precision Tower 5810, MDT, Windows 7: Storage Drivers (IASTORA.SYS)

Jump to solution

I've been deploying windows 7 for quite some time without issue with MDT.  I'm generally familiar with storage driver issues but this machine has me stumped.

After successfully booting to PXE windows PE environment and loading the image to the drive, I keep getting hit with the "Windows failed to start, IASTORA.SYS, 0xc0000098, Required file in missing or corrupt" error on the first reboot.   -So it appears the wrong storage driver is loading.

I have done the following:

I have realized the machine name changed from Precision 'T5810' to 'Tower 5810' (So my driver selection profile is correct)

Driver selection profile is both the 5810 CAB as well as files loaded from the service tag page -I've attempted to scale back older drivers thinking that perhaps an older bad copy is loading.  I think I'm loading v4.3

I've injected drivers into the WIM image using DISM just in case. (including the Samsung NMVe drivers)

I've attempted to use windows repair -it can't find the issue... also loaded drivers there without helpful results.

Drivers (I think) are the intel drivers with Plug and Play ID VEN  8086,  DEV 8D62

-I verified this because I can load windows 7 using the recovery DVD and there I saw the storage drivers loaded...

For everything above I have cycled between SATA emulation ATA, ACHI, RAID

BIOS looks good I think.. Secure boot is off, legacy options on.... Nothing umping out at me

It's driving me batty...

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Denver_80211
1 Copper

RE: Precision Tower 5810, MDT, Windows 7: Storage Drivers (IASTORA.SYS)

Jump to solution

Appears to be in the intel scsi adpater family "iaAHCI v4.3.0.1198"

Hop this helps someone else on the search

0 Kudos
6 Replies
Moderator
Moderator

RE: Precision Tower 5810, MDT, Windows 7: Storage Drivers (IASTORA.SYS)

Jump to solution

Denver_80211,

Did you downloaded the Intel Rapid Storage Technology Driver and install it into the system?  Click the link to download drivers on the Precision  5810.


0 Kudos
Denver_80211
1 Copper

RE: Precision Tower 5810, MDT, Windows 7: Storage Drivers (IASTORA.SYS)

Jump to solution

90% sure I have but I will try again.  might take few hours before I can test... meetings meetings

0 Kudos
Denver_80211
1 Copper

RE: Precision Tower 5810, MDT, Windows 7: Storage Drivers (IASTORA.SYS)

Jump to solution

Verified and refreshed the rapid storage drivers.  same result

0 Kudos
Denver_80211
1 Copper

RE: Precision Tower 5810, MDT, Windows 7: Storage Drivers (IASTORA.SYS)

Jump to solution

My replies keep going no place.. tried the suggested drivers -no luck

0 Kudos
Denver_80211
1 Copper

RE: Precision Tower 5810, MDT, Windows 7: Storage Drivers (IASTORA.SYS)

Jump to solution

After three days of tests (takes a while to load the OS each time):

Running!!!!! Looks like there is a bad driver the 5810 CAB (Error started right after loading the CAB and it stopped when I ripped out the drivers to narrow down what's tripping this up)

I'll start piecing together which driver is the problem child as best I can... hope to find it and post here

0 Kudos
Highlighted
Denver_80211
1 Copper

RE: Precision Tower 5810, MDT, Windows 7: Storage Drivers (IASTORA.SYS)

Jump to solution

Appears to be in the intel scsi adpater family "iaAHCI v4.3.0.1198"

Hop this helps someone else on the search

0 Kudos