Highlighted
aldenca
Copper

Problems reinstalling XP Home on Vostro 200

Hi

I haev a bit of issue/problem here. Due to protracted problems with a rootkit trojan I decide to reinstall XP onto my Vostro 200. Simple enough you would think, so I carried out the following steps

  1. powered down PC
  2. disconnected SATA drive to get Vostr to boot from the XP reinstall CD provided with the vostro (SP2)
  3. booted PC and then re-connected SATA driveonce booting OK from the CD
  4. selected the correct C: partition to reinstall onto
  5. selected a full format
  6. CD then went through the normal steps of installing XP and the rebooted to complete install
  7. at this point everything went slightly bad

the following message appeared

Windows copuld not start because the following file was missing or corrupted

<windowsroot>\system32\hal.dll

please re-install a copy of the above file.

I also have a full Microsoft supplied XP SP1A CD, so re-tried with this to the same effect.

Any help, ideas or pointers graefully received as the wife is waiting to do her on-line shopping for XMAS

 

 

0 Kudos
5 Replies

Re: Problems reinstalling XP Home on Vostro 200

Hello,

Here is a Microsoft page that deals with your problem.

Mis Dos Centavos,
Darrell

Gadfly at large

Helping Dell Customers here since 1998

My systems ...
Dimension XPS D266 - Now retired
Toshiba Tecra M1
Dimension 4300 - Received DOA as a gift. Reinstalled XP and still working great
Dimension 9150 - Pent D 3.2GHz, 4GB dual-channel 533 DDR2 Windows 7 Pro, Firefox 3.6.14
  Congrats to Jimmie Johnson #48 - FIVE time Nascar Sprint Cup Champ !!!!  

 

aldenca
Copper

Re: Problems reinstalling XP Home on Vostro 200

Thanks for your help. I looked at the MS knowledge base link you gave me and I tried option 2 (recovery console and bootcfg) to no effect. Options and 3 are out as there is no ability at this level to edit boot.ini.

I did then changed the attributes of the boot.ini, deleted it then used bootcfg /rebuild to set up the correct bootstring, then bootcfg /default to set as default boot.

the boot.ini now has

signature(d0f4738c)disk(0)rdisk(0)partiiton(1)\WINDOWS

which seems correct as 1 have one single partition.

All of which just produced the same result.

Next step taken was to use expand to refresh the hal.dll, agin to no effect.

Next step was to use diskpart to blow away the partition and then reinstall from XP reinstallation CD, again same result.

All ideas are now exhausted, the only option I can think of now is to try doing a Vista install.

 

Any further advice gratefully received.

PC :Vostro 200 4400 dual core 2 Ghz, 320GB SATA drive, 2GB DDR memory.

 

0 Kudos

Re: Problems reinstalling XP Home on Vostro 200

Hello again,

I don't have any other ideas right now, but I will keep this string open and think about it.

Watch your email notifications for a reply, as I don't know if or when I might find something else. Sorry

Mis Dos Centavos,
Darrell

Gadfly at large

Helping Dell Customers here since 1998

My systems ...
Dimension XPS D266 - Now retired
Toshiba Tecra M1
Dimension 4300 - Received DOA as a gift. Reinstalled XP and still working great
Dimension 9150 - Pent D 3.2GHz, 4GB dual-channel 533 DDR2 Windows 7 Pro, Firefox 3.6.14
  Congrats to Jimmie Johnson #48 - FIVE time Nascar Sprint Cup Champ !!!!  

 

0 Kudos

Re: Problems reinstalling XP Home on Vostro 200

Thanks for your help. I looked at the MS knowledge base link you gave me and I tried option 2 (recovery console and bootcfg) to no effect. Options and 3 are out as there is no ability at this level to edit boot.ini. ...

Hello again,

Look what I found for you.

Use this page to edit the boot.ini file from within the recovery console.

Mis Dos Centavos,
Darrell

Gadfly at large

Helping Dell Customers here since 1998

My systems ...
Dimension XPS D266 - Now retired
Toshiba Tecra M1
Dimension 4300 - Received DOA as a gift. Reinstalled XP and still working great
Dimension 9150 - Pent D 3.2GHz, 4GB dual-channel 533 DDR2 Windows 7 Pro, Firefox 3.6.14
  Congrats to Jimmie Johnson #48 - FIVE time Nascar Sprint Cup Champ !!!!  

 

aldenca
Copper

Re: Problems reinstalling XP Home on Vostro 200

Hi

It turns out that this was all down to a faulty (?) SATA drive. I swapped it out and used another drive and XP installed just fine.

Of course it could be that the rootkit.trojan had done something rather nasty to the mbr.

Thanks for your help

0 Kudos