mcatenacci
1 Copper

Trying to Reinstall XP after Vista on Dell Inspiron 6400

Hi all, My Dell came originally with XP Media Centre 2005, but I was eligible for the free Vista Upgrade. I upgraded to Vista and had that for about a year, but my computer is running really slow with it, so I wanted to go back. It wouldn't allow me to install XP over Vista because it was not compatible, so I decided to format the drive to be rid of Vista and start fresh with my original XP cd's and driver cd. I found the startup screen with the partitions, and I wasn't sure what they were all for, there's 4 partitions. I think I deleted the d: partition because I thought I didn't need it, I wanted all the space to be on one partition... I figured I don't use the media centre anyways, and would rather get rid of that wasted space, but not sure if that's even possible. ANYway, I formatted the C: to get rid of vista, and created a new partition on the C: (where I try to reinstall xp now)... I also formatted the 😧 and dont know what damage that caused. The other two partitions are still there untouched, dont know what they're for, one says the dell media direct. So I reinstalled XP on the C: and went through all the steps, my computer booted up with XP, only it's not at all how I first got it. My screen resolution only gives me 2 options, those icons on the bottom don't load so I can't even connect to the internet or do much of anything. I installed the drivers cd, but nothing seems to change even though it says they were added. I tried to repair xp by using the xp cd, and I get some kind of errors that says files are missing. Is this because I deleted the other partition?? I'm not sure what to do and get my xp looking normal again, please help!!! Not too technologically advanced, so I don't know why I attempted this. :( Michelle
0 Kudos
4 Replies
DELL-Larry R
4 Germanium

Re: Trying to Reinstall XP after Vista on Dell Inspiron 6400

The partitions as installed by Dell would be: Dell Media Direct, Onboard Diagnostics, Windows and Image Restore (the restore image).  The onboard diags partition is useful, but the Dell Resource (aka Drivers & Utilities) CD has the same diags if you boot from it.  The Image Restore partition is only going to work if the MBR is unchanged from (or repaired back to) how Dell set up the drive.  If you don't want to reload the out of box factory image then removing it gives you back a few gigabytes of space.

As for the system after reinstalling XP, it sounds like you have installed the software from the Resource CD, but haven't actually installed the required drivers.  The list of XP drivers, in the order they should be installed, for the 6400/E1505 is:

  • Dell™ Notebook System Software
  • Mobile Intel® Chipset Driver
  • Intel® 945GM/PM or ATI™ Mobility™ Radeon® X1300 / X1400 Video Driver
  • Ricoh® Media Card Reader Driver
  • Broadcom® 440X 100/100 Integrated Controller
  • Wireless Mini-Card driver (if applicable)
  • SigmaTel® STAC 9200 Audio Driver
  • MDC (modem) driver
  • Bluetooth® driver (if applicable)
  • Synaptics® TouchPad™ Driver
  • QuickSet utilities

 

0 Kudos
Highlighted
Hanspuppa
3 Argentium

Re: Trying to Reinstall XP after Vista on Dell Inspiron 6400

Dell-Larry R is right on with his suggestion. I might just clarify a item or two. You can delete all the partitions on the hard drive except for the first partition, which is hidden. It is only about 50-54 MBs. The 😧 partition is the Restore partition. Since you mention you have already deleted it, you cannot do a Dell Recovery Restore. That is the Recovery partition. When installing the OS, you can make the OS prtition (C) as large as it will go. This would insure that you are using all the hard drive capacity except for the first hidden partition. This can be removed also, but it is a rather complicated task that has to be done from the command line. I had a Dell 1505 and ran into this same situation and removed the hidden partition and created a single partition for the OS. You then will have to have downloaded all the drivers for the system as Dell-Larry R mentioned, then install them and all the programs you want, go to MS and downlaod and install all the updates and you should be fine. I did it and it worked well. Hope this helps as an addition to Dell-Larry R's instructions.

0 Kudos
mcatenacci
1 Copper

Re: Trying to Reinstall XP after Vista on Dell Inspiron 6400

Thanks for your help, I guess it is ok that I deleted that restore partition then, but I still wonder why I got a bunch of errors when installing xp, it was error after error of files that says are missing. I will try to repair tonight and write down the errors. It happened during installation, not when I'm actually in the Windows Operating System. I guess I just assumed the drivers were all installed when I installed the CD, I did not realize you have to go in and install each driver individually? I saw green check marks beside each item, so figured that meant it was installed. I will try that again too. I hope this works.
0 Kudos
mcatenacci
1 Copper

Re: Trying to Reinstall XP after Vista on Dell Inspiron 6400

Thanks for clarifying further. Of course I went and deleted the one partition I could've used LOL, but I'm not sure if it would've worked, maybe when i did the upgrade to Vista, it might have changed the ability to restore properly. I will keep things simple and leave the first partition as is. I will try to download the drivers off the cd individually until I can get online from that computer to do the rest. It's hard to know even which drivers I would need to get it back and running the way it was in the first place. Definitely helps Thanks Larry and Hanspuppa!
0 Kudos