sprokofiev
1 Copper

Windows 7 Installation

I have a Dell Precision M4800 computer, which came installed with Windows 8.1. I installed Windows 7 SP-1,  64-bit, and all seems to work well. EXCEPT that the computer cannot connect to to the internet via Wifi--red x over the bars icon, etc. I do have a nearby working hot-spot, but  it is undetected by the OS. I checked the BIOS settings and the Wireless Switch position. They are correctly set.  I navigated to the Device Manager screen; found no entry for "Network adapters", but there is an entry for "Network Controller",  with the driver reported as missing..

For comparison, I have a working Dell Latitude D630 computer, Windows 7, 32-bit, which doesn't  show a "Network Controller" but does show  a "Network adapters" entry which expands into two entries. The first is for a Broadcom controller, and the second is for an "Intel(R) PRO/Wireless 3945ABG Network connection".

so--I don't know exactly what is wrong, or what I should do about it. Suggestions are welcome.

0 Kudos
2 Replies
Philip_Yip
6 Indium

RE: Windows 7 Installation

There are variants in the network adapters for each model. The M4800 is newer than Windows 7 installation media therefore Windows 7 installation media lacks the drivers required. What are the hardware IDs?

http://dellwindowsreinstallationguide.com/checking-hardware-ids-in-the-device-manager/ 

Dr Philip Yip
Tech Enthusiast and Author of the Unofficial Dell Windows Reinstallation Guide

Windows FAQs and OEM Downloads


#IDoNotWorkFor Dell
0 Kudos
whences71
1 Copper

RE: Windows 7 Installation

I had the same trouble, it was almost successful

0 Kudos