Highlighted
johnboy100
1 Nickel

Windows update not working after installing windows 7 professional on a Dimension C521

Carried out a clean install deleting partitions and windows update has a red bar to the left and a red badge with a white x, no updates.

0 Kudos
13 Replies
7 Plutonium

RE: Windows update not working after installing windows 7 professional on a Dimension C521

The date and time must be correct.  You must have a live internet connection.

Then you download and run the update troubleshooter.

http://windows.microsoft.com/en-US/windows7/Open-the-Windows-Update-troubleshooter

 

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

0 Kudos
johnboy100
1 Nickel

RE: Windows update not working after installing windows 7 professional on a Dimension C521

Windows Update after operating system install,  I have checked date, time, location and have internet connection.  I had to open internet explorer and update to internet explorer 11, I have downloaded mse virus protection and run your link to update troubleshooter result below, no change to windows update. I updated from xp.  My bios version/ date dell Inc 1.0.3  02/10/2006.

0 Kudos
Moderator
Moderator

RE: Windows update not working after installing windows 7 professional on a Dimension C521

The 2006 Dimension C521 was only validated with Windows XP/Vista. When you installed Windows 7, how did you activate it with Microsoft?

0 Kudos
7- Thorium

RE: Windows update not working after installing windows 7 professional on a Dimension C521

Lots of people (including me) having issues with Win 7 updates recently. Read this.

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
johnboy100
1 Nickel

RE: Windows update not working after installing windows 7 professional on a Dimension C521

I activated from system properties with product key.

0 Kudos
Moderator
Moderator

RE: Windows update not working after installing windows 7 professional on a Dimension C521

Ok. Good to know. A non-activated system over time would not be able to do updates. Try the fix by RoHe.

0 Kudos
Philip_Yip
6 Indium

RE: Windows update not working after installing windows 7 professional on a Dimension C521

Windows 7 "Service Pack 2" is out. Install the following (32 or 64 Bit depending on your installed Operating System).

KB3020369 perquisite update for Windows 7 Service Pack 2 32 Bit:

https://download.microsoft.com/download/C/0/8/C0823F43-BFE9-4147-9B0A-35769CBBE6B0/Windows6.1-KB3020...

KB3020369 perquisite update for Windows 7 Service Pack 2 64 Bit:

https://download.microsoft.com/download/5/D/0/5D0821EB-A92D-4CA2-9020-EC41D56B074F/Windows6.1-KB3020...

Restart after installation of KB3020369.

KB3125574 Windows 7 Service Pack 2 32 Bit:

http://download.windowsupdate.com/d/msdownload/update/software/updt/2016/05/windows6.1-kb3125574-v4-...

KB3125574 Windows 7 Service Pack 2 64 Bit:

http://download.windowsupdate.com/d/msdownload/update/software/updt/2016/05/windows6.1-kb3125574-v4-...

You will be up to date to April 2016... Retry Windows Update...

Dr Philip Yip
Tech Enthusiast and Author of the Unofficial Dell Windows Reinstallation Guide

Windows FAQs and OEM Downloads


#IDoNotWorkFor Dell
0 Kudos
johnboy100
1 Nickel

RE: Windows update not working after installing windows 7 professional on a Dimension C521

RoHe download took me to windows update standalone installer searching for windows updates, half an hour later internet explorer had to close.  I rebooted and downloaded service pack 2 from natakuc4 which downloaded and installed i rebooted and strangely i am still on service pack 1.  Is it possible to carry out a clean install of windows 7 professional  from microsoft and might this be an option

0 Kudos
Moderator
Moderator

RE: Windows update not working after installing windows 7 professional on a Dimension C521

Moving this to the Microsoft operating system board since it is not a General Hardware issue.

0 Kudos