Highlighted
arnon
Bronze

"Unable to open this internet shortcut..."

Hi,
I have both IE & Mozilla Firefox for browsers, with FF as my default. I often save website shortcuts (or "deskcuts" in Firefox) to my desktop. Until recently, they'd work fine, opening up a new tab in the browser.

Now I get this pop-up error message whenever I try to double-click a desktop url shortcut:

http://img86.exs.cx/img86/7516/http-noregisteredprogram.jpg

I have no idea where to look in windows to rectify the issue. Anyone?...
TIA.
0 Kudos
5 Replies

Re: "Unable to open this internet shortcut..."

Does this error happen in IE as well as Mozilla?
0 Kudos
arnon
Bronze

Re: "Unable to open this internet shortcut..."

Neither browser responds regardless of which is the default.
If I drag the shortcut to a new tab in the Firefox browser, it does open & I'd imagine something similar could be done for IE, however, I'm not concerned with IE. This is a Windows issue.

If anyone can give me some tips as to where to go to associate a 'registered program with the protocol http', that would get me on my way...
Thanks.
0 Kudos
Denny Denham
Diamond

Re: "Unable to open this internet shortcut..."

arnon,

Open Windows Explorer and go to Tools|Folder Options|File Types tab. Scroll down to URL Internet Shortcut. In the details it should indicate that that type opens with Shell Doc Object and Control Library. If it doesn't click the Change button and select that from the menu. If it is not shown on the menu, browse to C:\Windows\System32\shdoclc.dll.

0 Kudos
arnon
Bronze

Re: "Unable to open this internet shortcut..."

Thanks for the reply, Denny.

I found 'URL Internet Shortcut' in File Types, but it was already associated with "Shell Doc Object", so I wasn't able to change anything, even after pressing the
"Restore" button. I attempted to enable Firefox as the registered program & then restarting the pc...nothing.
I went back to folder options and looked for "http" as that is what's mentioned in the error message. It wasn't there, but I did find "htm" & "html". I tried altering the registered programs just sto troubleshooot, but that had no effect either, and I restored them afterwords.

If it helps you any, this what the current details look like for the url shortcut:
http://img11.exs.cx/img11/8171/url-shortcut-details1.jpg

Here's what the properties of an actaul desktop shortcut looks like (note that there is nothing entered in the shortcut key bar):
http://img11.exs.cx/img11/7985/url-shortcut-details2.gif
0 Kudos
batyan
Bronze

Re: "Unable to open this internet shortcut..."

I have the same problem and the same resalt.

So change in Folder Options doesnt work.

Any ideas?

Smiley Wink

0 Kudos