Wyse Device Manager

Last reply by 04-29-2021 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Wyse 5070 ThinOS 9.x downgrade to 8.6

Hi - I need to downgrade several wyse terminals from ThinOS 9.x to 8.6 and I am using the following instructions to do so: https://www.meinekleinefarm.net/howto-dell-wyse-thinos-downgrade-from-9-0-to-8-6/

I have the following driver and to my knowledge I have properly used the USB imaging tool: 


However when I start up the Wyse terminal, holding F12 I cannot see the USB drive so I am wondering it is because it might be incompatible? I have tried a Q-Connect and a DataTraveler 100 G3 so far and neither has worked.

Help would be greatly appreciated!

Replies (7)
3 Zinc

Check 2 things in BIOS

1) Enable boot from USB

2) Disable secure boot


Thanks for the reply. I have done so and have made more progress than before.

Now, however, everything freezes when I get to the USB imaging tool screen, I can see the image to pull and there is a loading bar stuck at 1%.

I am using a SanDisk 32GB 3.0 USB which I believe should be compatible but there might be some other issues with my set up, any ideas?


Try the different USB ports (front and back) to see if there is a difference in results.  I seem to recall something about the USB3 (blue) ports. 

Also, It isn't very intuitive, but make sure you are clicking the OK button in the lower right to start the process. 

If you are still getting a hang, please share the picture.


Hi - have tried all USB ports and still no luck, always the same result getting stuck at the Image Pull screen (see attached) also included the original set up screen that appears on the start.

Note that on the imaging screen everything is frozen, cannot even move the mouse so I have to manually switch it off. 

So wondering if it could be an issue with the Image that I pushed onto the USB given that this is my first ever attempt at this, seems probable. 


here is the link I used: https://www.dell.com/support/home/en-uk/drivers/driversdetails?driverid=47xrv&oscode=thn8p&productco...

Any other ideas? I have spoken to Dell support on a number of occasions but that hasn't lead to anything.




Maybe I am missing an image but.

In the second image, you have to click on the image name, then OK to start the process. 

Can you send a picture of when it hangs at 1%?


Yes see below. The problem is that I cannot move the mouse or press enter, cannot even escape. It is totally frozen and only switching off the power works. I have tried to leave it for like an hour and still nothing wants to work.



That i have not seen before. 


Latest Solutions
Top Contributor