WinkDk
1 Nickel

Connecting Wyse3040 to VDI Personal Desktop - Gateway Issue

Jump to solution

Hallo,

I have been playing around with this issue for way to long, so I thought I would ask around here as well.

Our current way of going about connecting:

Dell Wyse 3040 client connects to our RemoteApp, where it is supposed to start the users Personal Desktop from our VDI environment. This work for the most part, except for the connection to the Personal Desktop. I receive an error when trying to make a connection, but if i go and modify the RDS shortcut, i can see that it sets the option "Use Ts Gateway" and makes it equal to our RemoteApp server. Is it possible to uncheck this option from a WMS point of view, as i would like to be able to control all of our Thin clients from there, rather than having to do it manually 1by1 on them.

If I remove the check mark in the option "Use Ts Gateway", it will work without any problems regarding connection to the Personal Desktop, but as soon as the Terminal is restarted, it reverts to having the option checked off again, which makes it go into an error instead of connecting.

Our OS:

VDI client: windows 7 Pro

Session host / broker: Windows 2016

ThinOs: Dell Wyse 3040 (Firm, 8.5_012)

WMS: 1.2.0 40299

 

The error i receive:

11:38:52.361 Start session to *****.********.*****
11:38:52.394 RDP: Connect to *****.********.*****
11:38:52.926 TSG3 connection setup
11:38:52.955 RDP: NLA CredSSP Authentication
11:38:52.987 KRB: Server not found in Kerberos database. Error code:7
11:38:53.523 KRB: Server not found in Kerberos database. Error code:7
11:38:54.559 KRB: Server not found in Kerberos database. Error code:7
11:38:54.594 KRB: Server not found in Kerberos database. Error code:7
11:38:54.635 RDP: Create network detection channel
11:38:55.176 RDP: Start session to **.**.*.* (* = IP of Personal Desktop)
11:38:55.213 RDP: Connect to **.**.*.* (* = IP of Personal Desktop)
11:38:55.250 TSG3 connection setup
11:38:55.287 RDP: Resource can’t be connected.
11:38:55.324 RDP: TSG3: Can’t connect to [****-****.********.*****] through gateway. (* = FQDN of the Personal desktop)
11:38:55.399 ERROR: Connection Failed!

 

 

0 Kudos
2 Replies

Re: Connecting Wyse3040 to VDI Personal Desktop - Gateway Is

Jump to solution

It is not clear in your description if you are using WMS to point at an RDS broker, or a direct connection. 

If you are using a broker under "Remote Connections (8.5+), Microsoft RDP Settings, then at the bottom there is a check box for "Auto-Detect Network+", Try unchecking that.

If you are using a direct connection object, scroll to the bottom and try unchecking "Use Terminal Server Gateway".

You could also try and define the setting manually in the "Advanced" section, and use the option 

SessionConfig=RDP TSGWEnable=no

 

 

 

WinkDk
1 Nickel

Re: Connecting Wyse3040 to VDI Personal Desktop - Gateway Is

Jump to solution

Thanks for you input @buffalobound

WMS is pointing to my RemoteApp address / broker.

I went and unchecked the field "Auto-detect Network", but it doesn't seem to change anything. The "use Ts Gateway" option is still checked off after a restart.

 

But this seem to have resolved the issue:

Going to Advanced section, and enter SessionConfig=RDP TSGWEnable=no

 

Thank you very much Smiley Happy