1 Copper

Intermittent Issues with serial port on Wyse 7010 (Z90D7)

We are testing a newer Wyse client (Z90D7 model, Wyse Linux) that has a serial port connection to a PC. We have an external customer that uses a dedicated piece of equipment, however the PC is what we use for testing. We run a C# application on the clients via a Citrix ICA. When we run the application that we are using on our old Wyse equipment, everything runs fine with no errors. However, on the new equipment, the serial port only works probably a little less than half the time (on average). All of the other times, it will give me either an Overrun error, a Parity error, or an RXOver error.

I have verified through logging that the port does open and several commands execute after it opens. However, the random errors happen before any actual data can even be transmitted. I've read in numerous places that this could be a buffer issue, however I have not seen any posts mentioning errors happening before data is received so I'm not entirely sure.

I have also tried to use handshaking and larger read/write buffers with no luck. I have tried a new cable and the 2nd COM port on this device, no luck either. Our default settings are:

9600 baud, even parity, 8 data bits, 1 stop bit

Given that this is running on Citrix, we also have to run the net use commands shown here before anything is done. Not doing so will result in the serial connection always saying it's connected and not receiving any data (this happens on the old equipment as well). The exact command we're executing (with the app name changed, of course) is:

net use com1 /DELETE
net use com2 /DELETE
net use com1: \\client\com1:
net use com2: \\client\com2:
start /d "D:\myapp" MyApplication.exe

Has anyone who has dealt with serial ports ever heard of these three errors alternating like this? Is there anything other than a faulty port (or two faulty ports, rather) that could cause this? I'm thinking that the hardware buffer size could be the issue, but can't find any way to overcome this and have not found any occurrences similar to this with this equipment.

I had also posted this to the Superuser stack exchange site, but had no luck with an answer.

0 Kudos