Highlighted
Diamond

CCM Error

Jump to solution

Hi, guys i have the next issue, when i try to registry one particular Wyse 3040 i get the next errors

 Log:

09:31:44 CCM Agent validate register failed to write error!.
09:31:44 CCM Agent failed to register, can't retrieve registration info.
09:31:44 CCM Anget failed to validate CCM Settings. Please inform to you CCM IT Admin

 

Note: i have 50 Wyse3040 Working whitout problems, the only wyse that presents this problem is this, previously this equipment was registered in the WMS but I present a problem and sent a guarantee now that return does not want to register in the WMS.

 

0 Kudos
4 Replies
Diamond

Re: CCM Error

Jump to solution

ok, i foun the error on logs

 

org.springframework.dao.DuplicateKeyException: Write failed with error code 11000 and error message 'E11000 duplicate key error collection: stratus.devices index: tenantId_serialNum_1 dup key: { : "2_3GHDWJ2" }'; nested exception is com.mongodb.DuplicateKeyException: Write failed with error code 11000 and error message 'E11000 duplicate key error collection: stratus.devices index: tenantId_serialNum_1 dup key: { : "2_3GHDWJ2" }'

 

how to deal whit this error? 

0 Kudos
Diamond

Re: CCM Error

Jump to solution

That sounds like you possibly already had it registered in WMS, then removed it, but a table entry is still present for it.   Is this the case?

Have you searched through WMS to make sure it was force removed?  If you can find no reference to it then it will likely need to be manually removed from the database.  I would suggest opening a support ticket to get guidance.

 

 

0 Kudos
Diamond

Re: CCM Error

Jump to solution

from the administrator I told him to force the deletion of the wyse with the id 3GHDWJ2, when I executed it indicated that it was satisfactory, but even so the error continues, if I already open a ticket with a dell support I am waiting for an answer.

0 Kudos
Diamond

Re: CCM Error

Jump to solution

Solution:

 

1 - Install and IDE MongoDB

2 - Logedin to t the database using user: stratus and password of the installation

3 - go to table devices and find the json of the devices ID error on field tenantid_serialNum: 2_3GHDWJ2

4 - copy and save the json and then deleted.

5 - try the registration again... and now is working.

Ready now the wyse is registered on the WMS