Wyse Management Suite

Last reply by 08-24-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Can't authenticate to Wyse Management Suite API (Cloud)

I'm trying to connect to the Wyse Management Suite API in the Cloud, but I keep getting a 500 error.  I've tried from both PowerShell and Postman (instructions here), but no luck.  I did ask my admin to verify that WMS API is enabled according to this article, which it is.

Does anyone have any pointers for how to get past this?



Replies (6)
3 Zinc

I would suggest opening a support case using the service tag for WMS (Which you can retrieve from the Dell Digital Locker) for assistance.

2 Bronze
2 Bronze

Just spoke with support, and the reason for the error seems to be that we have 2FA enabled for the cloud instance.  At this time the API does not work when 2FA is enabled.

I was told that to put in a feature request for this, you have to talk to the sales person for the account. I'll be doing that next.


Looks like the 2FA restriction was lifted for the API with the WMS 3.8 release the other day. 

Tried it again yesterday and was able to connect now.


Did you do anything special to make this work?  I am getting an "invalid credentials" message. I guess that's an improvement from a generic 500 error though.


Was able to connect using POSTMan and powershell. I believe the user you are authenticating with needs to be a global admin. Sample powershell to get a token. 

$username = "XXXXXXXXX"
$password = "XXXXXXXXXXXXXX"
$body = @{    
    UserName  = $username
    Password  = $password
$token = Invoke-WebRequest -Method POST -Uri $authURI -Headers @{"accept"="application/json"} -Body ($body | ConvertTo-Json) -ContentType 'application/json'
$XAuthToken =  $token.Headers.'X-Auth-Token'

I have tried using this to work with our on premises system, and I can't get it to work or get help on it. We are running WMS 3.3.1, but I have also tested on 3.5. I have the API enabled, I have a global admin user that I am using to login. We use proxies on our network, so I have configured the scripts to use proxies (and they do so successfully). But I cannot get an X-Auth-Token returned. All I get is 401 error saying "The authentication token header is missing in the request. Please sign-in with URL /wms/v1/SessionService/Sessions." But that is exactly what I am doing in the scripts. I can find no useful information about what the problem might be. Are we supposed to configure something under "External App Services?" I have tried that, too, but I don't know what we are supposed to with this...it generates an API key and a key secret, and with other APIs I have worked with, this was the information used to connect, but that doesn't seem to be the case here(?) This API feature is so confusing because there is very little useful information provided by Dell. So when I see that someone apparently has *something* working, I try to find out how. I don't want to ask Dell technical support as they are just going to tell me to upgrade to the bleeding edge version of WMS, *and we are not prepared to do that at the moment*, plus, I have no guarantee that the API situation will be any better there.

Latest Solutions
Top Contributor