Wyse Management Suite

Last reply by 08-05-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
1958

Upgrade failure - WMS 3.2 / 3.3.1 to WMS 3.5 / 3.5.1 /3.5.2: Failed to start MariaDB service

Hello together,

As described in the subject, the upgrade breaks when trying to start the MariaDB.

Key points:
- Current Version WMS 3.3.1
- Windows Server 2016

- Upgrade from 3.2 to 3.3.1 works fine
- Upgrade from 3.2 / 3.3.1 to 3.5 / 3.5.1 or 3.5.2 failed
- Target Version 3.5.2 (log4j ...)

An uninstallation and reinstallation had worked, only the upgrade does not work on the latest version.

wms1.jpg

 

The following are excerpts from the logs:

Spoiler

Dell WMS Upgrade Logs:

2022-1-4 T11:37:24::CustomFunctions::6184::In Function Grant Log on as service
2022-1-4 T11:37:24::CustomFunctions::6196::Updated MySQL Log On as a Service: The operation completed successfully.

2022-1-4 T11:37:25::Upgrade::5290::Starting MariaDB service
2022-1-4 T11:37:35::Upgrade::5295::
...
2022-1-4 T11:52:09::Upgrade::5295::
2022-1-4 T11:52:14::Upgrade::5304::Failed to start MariaDB service: Incorrect function.


Windows Application Logs (Source: MySQL - Event ID: 100):

Information: C:\Programme\DELL\WMS\MariaDB\bin\mysqld.exe (mysqld 10.2.29-MariaDB) starting as process 6776 ...
Information: InnoDB: Mutexes and rw_locks use Windows interlocked functions
Information: InnoDB: Uses event mutexes
Information: InnoDB: Compressed tables use zlib 1.2.11
Information: InnoDB: Number of pools: 1
Information: InnoDB: Using SSE2 crc32 instructions
Information: InnoDB: Initializing buffer pool, total size = 2G, instances = 2, chunk size = 128M
Information: InnoDB: Completed initialization of buffer pool
Error: InnoDB: The innodb_system data file 'ibdata1' must be writable
Error: InnoDB: Plugin initialization aborted with error Generic error
Information: InnoDB: Starting shutdown...
Error: Plugin 'InnoDB' init function returned error.
Error: Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
Error: mysqld.exe: File 'C:\Programme\DELL\WMS\Database\SQL\aria_log_control' not found (Errcode: 13 "Permission denied")
Error: mysqld.exe: Got error 'Can't open file' when trying to use aria control file 'C:\Programme\DELL\WMS\Database\SQL\aria_log_control'
Error: Plugin 'Aria' init function returned error.
Error: Plugin 'Aria' registration as a STORAGE ENGINE failed.
Information: Plugin 'FEEDBACK' is disabled.
Error: Unknown/unsupported storage engine: InnoDB
Error: Aborting


Windows System Logs (Source: Service Control Manager - Event ID: 7034)

Error: The Dell WMS: MariaDB service terminated unexpectedly. It has done this 1 time(s).

 

Have no idea how to proceed.

BG

 

Replies (4)
2 Bronze
2 Bronze
1939

I tried some more things and found the following:

After upgrading from WMS 3.2.x to WMS 3.3.x / 3.5.x the MariaDB version is not updated anymore. The database version remains at 10.2.29 even though the binaries are e.g. 10.2.35 or newer.

However, the WMS 3.3.x versions work fine, only the upgrade to 3.5.x seems to do something to the database and it goes wrong.

After a clean installation of the WMS 3.5.2 the MariaDB database and the binaries have the version 10.2.40.

2 Bronze
2 Bronze
1899

Hello,

For me, after upgrade 3.3.1 -> 3.5 OK  and after 3.5 -> 3.5.2 NOK.

MariaDB folder located here "C:\Program files\DELL\WMS\MariaDB" was missing.

So i created manually.

I downloaded the binaries from MariaDB website with the version 10.2.40 provided by sgs1.

https://archive.mariadb.org//mariadb-10.2.40/winx64-packages/mariadb-10.2.40-winx64.zip

I extracted the bin folder and keep only the mysqld.exe inside and copy the bin folder into "C:\Program files\DELL\WMS\MariaDB".

After that, website didn't work. (blank page) so i gone to services.msc and edit Dell MariaDB service.

I changed the username and password of logon user to execute this service.

Username is .\WMSUser and password (password provided during the installation of your 3.5 version).

For me these steps solved my upgrade issue.

Now my WMS is in 3.5.2 and works well.

1581

I want to confirm that the fix published by @PierreW9560 did work well for me.

I was facing the issue when trying Upgrade from WMS 3.5.2 -> WMS 3.6

The Installation broke and the folder ""C:\Program files\DELL\WMS\MariaDB" was nearly empty after the upgrade attempt.

IMPORTANT: You need to BACKUP your MariaDB/MySQL before the upgrade to have the chance to restore the MariaDB when it breaks.

@DELL, it would be interesting to understand why sometimes the MariaDB folder / DB is crashing during the WMS Upgrade installation.

Thanks,

Hansjörg

2 Bronze
2 Bronze
581

Hi,

i tried update WMS 3.3.1.29 to 3.5.2 but after "successfull" upgrade the MariaDB folder missing and i cannot start the mariadb service, so i had 404 error page. I shutdown the VM and reverted to the snapshot before starting upgrade ! i dont undrestant, why is folder MariaDB is deleted after upgrade :)))) 

Latest Solutions
Top Contributor