bobcomer
1 Nickel

Authentication bug in version 2.2.223

Exclamation Authentication bug in version 2.2.223

Hi,

we have 2 iPad's here with PocketCloud Pro on them and when it is updated to version 2.2.223, they were no longer able to connect to our RDP client machine.

After some playing around with it I notcied that it was no longer asking for credentials when starting up a connection and that's the problem. We don't save the password on the iPad for security reasons, and it always asked for that before attempting the connection until v2.2.223, now it just starts the connection and then errors out saying it cannot connect.

I figured out a workaround, key the password in the connection settings, connect to the server, disconnect, erase the password from the settings, then on your next connection you get the normal Windows login dialog. (you don't get the Pocketcloud request for credentials like you should, but at least you can connect.

The only odd thing in out setup is that we don't use the default RDP port, but that's never been an issue.

--
Bob Comer

0 Kudos
12 Replies
Azriphale1
1 Copper

RE: Authentication bug in version 2.2.223

Same issue with VMware View

We seem to have the same issue when connecting to a VMware view computer. This is not behaviour I would expect from a business tool.

It also appears that a number of the optional connection settings are, in fact, not optional. What is particularly irritating about this is that some of these setting only have one possible value, so why does it have to be manually selected? Again, this does not give the impression that pocket cloud is a polished enterprise application.

For reference, we are using View 4.5 with PocketCloud Pro 2.2.223.

0 Kudos
bobcomer
1 Nickel

RE: Authentication bug in version 2.2.223

Quote Originally Posted by Azriphale View Post

It also appears that a number of the optional connection settings are, in fact, not optional. What is particularly irritating about this is that some of these setting only have one possible value, so why does it have to be manually selected? Again, this does not give the impression that pocket cloud is a polished enterprise application. 
 
 
I think what you're talking about are all "on/off" type settings, rather than just being for show, at least they are here.

PocketCloud actually works pretty well for us here and the users are happy with it. (including me. <g>)

0 Kudos
awcwong
1 Copper

RE: Authentication bug in version 2.2.223

I experienced the same issue with remote desktop as well. Just updated to 2.2.223, and now I cannot connect. I use non default port for rdp and does not store password.

Did Wyse do testing before releasing this low quality update?

0 Kudos
8 Krypton

RE: Authentication bug in version 2.2.223

Thanks for the feedback guys. Unfortunately I'm not able to duplicate your issues. Any specific steps I should follow?

0 Kudos
awcwong
1 Copper

RE: Authentication bug in version 2.2.223

Chris, you may want to ensure 1. non-default server port 2. do not store password in the configuration 3. start from a build earlier than 2.2.3 then upgrade to 2.2.3.

Bobcomer, thanks for your workaround below. It worked for me.

I figured out a workaround, key the password in the connection settings, connect to the server, disconnect, erase the password from the settings, then on your next connection you get the normal Windows login dialog. (you don't get the Pocketcloud request for credentials like you should, but at least you can connect.

0 Kudos
bobcomer
1 Nickel

RE: Authentication bug in version 2.2.223

awcwong's steps to reproduce it are what I would have said, though I created a new connection under 2.2.3 and it had the same problem. I'll try it on a standard port RDP here in a minute to see if it makes a difference here and let you know.

0 Kudos
bobcomer
1 Nickel

RE: Authentication bug in version 2.2.223

Okay, you don't error out if it's a non standard port, so that's part of the problem, but you don't get the pocketCloud request for credientials before it tries to connect like you used to. Luckily I still have a device at the older version to check and it definitely asks for credentials before it tries to connect, no matter the port.

0 Kudos
8 Krypton

RE: Authentication bug in version 2.2.223

We removed the credentials prompt for Non-NLA connections as we had a lot of users complain about it. You will still be required to login, but instead of entering your username/password on the pop-up, you will login on the Windows screen instead. If you want the prompt back then you should enable NLA on your desktop.

-Chris

0 Kudos
Highlighted
bobcomer
1 Nickel

RE: Authentication bug in version 2.2.223

Quote Originally Posted by Chris View Post

We removed the credentials prompt for Non-NLA connections as we had a lot of users complain about it. You will still be required to login, but instead of entering your username/password on the pop-up, you will login on the Windows screen instead. If you want the prompt back then you should enable NLA on your desktop.

-Chris 
 
Thanks for your respnse Chris. That still shows as a bug because you cannot authenticate if it's a non standard port without using my workaround... (when setting up new connections, you cannot connect.)

NLA is a serious non starter for here, but I'd really like the option to have the old authentication request back, it's much easier to use. So I guess just make it a feature request...

-- 
Bob Comer
0 Kudos