jrhine-2015
1 Copper

Issue with VMware View connections?

Issue with VMware View connections?

Since upgrading to PocketCloud 2.0, we've been unable to connect to desktops in our VMware View environment. Connections that carried over from the 1.x versions always time-out when trying to connect (RDP port 3389). 

Our environment is currently NOT using SSL, and I noticed that when creating a new connection, the SSL setting always toggles itself back on after each field you complete on the settings page, regardless if you turn it off or not. 

View connections in PocketCloud 1.x always used the RDP port (3389) as default, and View connections now populate port 80 (when not using SSL that is) or port 443 (SSL). When I create a new connection and leave Port 80 set, the app crashes when you try to connect. 

Any advice on how to get this working again?

Tags (2)
0 Kudos
5 Replies
Daniel-2015
2 Iron

RE: Issue with VMware View connections?

jrhine,
We apologize for this inconvenience. In the 2.0 release we added support for custom HTTPS ports (that's why the default port shows as 443 as opposed to 3389) and we enabled SSL connections by default. We have been able to reproduce some of the issues you report and will try to address them in the upcoming Maintenance release. We'll investigate this further and will try to get back to you shortly with a workaround.

Tags (3)
0 Kudos
jrhine-2015
1 Copper

RE: Issue with VMware View connections?

Thanks very much for the info! If any additional information from our environment would be helpful in getting this resolved in PocketCloud, please feel free to contact me.

Tags (2)
0 Kudos
Suchitha
3 Argentium

RE: Issue with VMware View connections?

Hi jrhine,

sorry for the trouble. we have a workaround. hope that works for you too.
1. if you are creating new connections, please enable ssl once at the server. create your connections with ssl on.
2. now disable ssl on the server and edit your connections . just turn off ssl . dont edit anything else. 
3. you should be able to connect.

Tags (3)
0 Kudos
Suchitha
3 Argentium

RE: Issue with VMware View connections?

For existing 1.3 connections please try updating the port to 80 and do not edit anything else. Thanks! let me know your results as well. sorry for the trouble.

Tags (2)
0 Kudos
Highlighted
Suchitha
3 Argentium

RE: Issue with VMware View connections?

shorter workaround

For new connections,
1.just a create a new connection with ssl on with the minimum nickname, username and password.
2. edit connection and turn off ssl and update domain, desktop.

Tags (2)
0 Kudos